вентилятор
Волк

Демоверсия ЕГЭ по информатике 2023 (Задания 1-5)



Сегодня решим демоверсию ЕГЭ по информатике 2023.


Условия задач были взяты с сайта: https://fipi.ru/ege/demoversii-specifikacii-kodifikatory#!/tab/151883967-5


Серьёзные изменения коснулись шестого, двадцать второго задания.


Видеокурс по подготовке к ЕГЭ по информатике на 90% остаётся актуален.



Демоверсия ЕГЭ по информатике 2023 (Задания 6-10)
Демоверсия ЕГЭ по информатике 2023 (Задания 11-15)
Демоверсия ЕГЭ по информатике 2023 (Задания 16-21)
Демоверсия ЕГЭ по информатике 2023 (Задания 22-27)





Задание 1

На рисунке схема дорог Н-ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).


Демоверсия ЕГЭ по информатике 2023 - Задание 1

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова сумма протяжённостей дорог из пункта D в пункт B и из пункта F в пункт A.

В ответе запишите целое число.


Решение:

Город B двойной и связан с двумя тройными. Значит, 5 - В. Один из этих тройных городов связан с двойным городом (городом С). Получается 2 - F. Город C связан с 3, значит 3 - G. Город G связан с 6. Т.е. 6 - E. Пункт 7 - это D. Это мы знаем, т.к. город В уже найден.A получается 5.


Демоверсия ЕГЭ по информатике 2023 - Задание 1 Решение

От B до D расстояние 53. От F до A расстояние 5. В ответе напишем 53 + 5 = 58.


Ответ: 58



Задание 2

Миша заполнял таблицу истинности логической функции F


¬(y → x) ∨ (z → w) ∨ ¬z,

но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.


Демоверсия ЕГЭ по информатике 2023 - Задание 2


Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.


Пример. Функция F задана выражением ¬x \/ y, зависящим от двух переменных, а фрагмент таблицы имеет следующий вид.


Задание 2 ЕГЭ по информатике демоверсия 2022 пример

В этом случае первому столбцу соответствует переменная y, а второму столбцу – переменная x. В ответе следует написать: yx.





Решение:

Есть замечательный шаблон для решения 2 задания на Питоне, о котором было рассказано в бесплатном видеокурсе.


print('x y z w')

for x in range(0, 2):
    for y in range(0, 2):
        for z in range(0, 2):
            for w in range(0, 2):
                if not( not(not(y) or x) or (not(z) or w) or not(z) ):
                    print(x, y, z, w)

Демоверсия ЕГЭ по информатике 2023 - Задание 2 решение


В каждом столбце есть ноль. Следовательно, переменная z идёт в предпоследний столбец. И в этом столбце все единицы. Тогда w идёт в последний столбец. Там все нули.


Первая строка в синий таблице, которую мы получили, имеет одну единицу. Это может быть только первая строчка. Допишем в первой строчке ноль. Получается первый столбец имеет два нуля и одну единицу, значит, это столбец y.


Второй столбец достаётся x.


Ответ: yxzw



Задание 3

В файле приведён фрагмент базы данных «Продукты» о поставках товаров в магазины районов города. База данных состоит из трёх таблиц.


Таблица «Движение товаров» содержит записи о поставках товаров в магазины в течение первой декады июня 2021 г., а также информацию о проданных товарах. Поле Тип операции содержит значение Поступление или Продажа, а в соответствующее поле Количество упаковок, шт. занесена информация о том, сколько упаковок товара поступило в магазин или было продано в течение дня. Заголовок таблицы имеет следующий вид.


ID
операции
Дата ID
магазина
Артикул Тип
операции
Количество
упаковок,
шт.
Цена,
руб./шт.

Таблица «Товар» содержит информацию об основных характеристиках каждого товара. Заголовок таблицы имеет следующий вид.


Артикул Отдел Наименование Ед.
изм.
Количество
в упаковке
Поставщик

Таблица «Магазин» содержит информацию о местонахождении магазинов. Заголовок таблицы имеет следующий вид.


ID
магазина
Район Адрес

На рисунке приведена схема указанной базы данных.


Задание 3 демоверсия ЕГЭ по информатике 2022

Используя информацию из приведённой базы данных, определите общий вес (в кг) крахмала картофельного, поступившего в магазины Заречного района за период с 1 по 8 июня включительно.


В ответе запишите только число.


Скачать файлы




Решение:

Найдём артикл крахмала картофельного.


Открываем вкладку "Товар", нажимаем Ctrl + F и ищем крахмал картофельный. Артикл у этого товара получается 42. Так запомним, что в одной упаковке 0,5 кг данного товара.


Найдём ID магазинов, которые находятся в Заречном районе. Переходим на вкладу Магазин. Кликаем в ячейку B1, выбираем кнопку на вкалдке "Главная" -> Сортировка и фильтр -> Фильтр.


Задание 3 демоверсия ЕГЭ по информатике 2022 - решение через фильтры

Отфильтровываем магазины, которые находятся в заречном районе.


Задание 3 демоверсия ЕГЭ по информатике 2022 - отфильтровываем магазины

Получаются ID магазинов: M3, M9, M11, M14.


После этого, переходим на вкладку "Движение товаров". Так же включаем фильтры и оставляем только нужный артикл крахмала картофельного и нужные ID магазинов.


Если ещё отфильтруем товары по типу "поступления", мы узнаем сколько килограмм крахмала картофельного пришло в нужные нам магазины.



Все строчки датируются 3 числом, значит, эти движения товаров укладываются в указанный временной диапазон.


Выделяем ячейки из столбца Количество упаковок. Внизу программа покажет сумму выделенных ячеек. Примечание: здесь нельзя пользоваться стандартной функцией СУММ, потому что эта функция просуммирует и скрытые ячейки.


Получается, что в указанные магазины поступило 710 упаковок.


Значит, поступило 710 * 0,5 = 355 кг.


Ответ: 355



Задание 4

По каналу связи передаются сообщения, содержащие только буквы из набора: А, З, К, Н, Ч. Для передачи используется двоичный код, удовлетворяющий условию Фано. Это условие обеспечивает возможность однозначной расшифровки закодированных сообщений. Кодовые слова для некоторых букв известны: Н - 1111, З - 110. Для трёх оставшихся букв А, К и Ч кодовые слова неизвестны. Какое количество двоичных знаков постребуется для кодирования слова КАЗАЧКА, если известно, что оно закодировано минимально возможным количеством двоичных знаков.



Решение:

Расположим уже известные буквы на дереве Фано.


Реальный экзамен ЕГЭ по информатике 2022 - Задание 4 (Дерево Фано)

У нас остались три свободных места, если не продливать дерево: 0, 10, 1110.


Буква А встречается в слове КАЗАЧКА аж 3 раза. Значит, букве А присвоим код 0. Буква К встречается один раз, значит, ей код присвоим чуть побольше 10. Букве Ч достаётся код 1110. Это самый оптимальный способ распределить коды между оставшимися буквами.


Всего минимальная длина закодированного слова будет: 2 (К) + 1 (А) + 3 (З) + 1 (А) + 4 (Ч) + 2 (К) + 1 (А) = 14.


Ответ: 14



Задание 5

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.


1. Строится двоичная запись числа N.


2. Далее эта запись обрабатывается по следующему правилу:

a) если сумма цифр в двоичной записи числа чётная, то к этой записи справа дописывается 0, а затем два левых разряда заменяются на 10;

б) если сумма цифр в двоичной записи числа нечётная, то к этой записи справа дописывается 1, а затем два левых разряда заменяются на 11.


Полученная таким образом запись является двоичной записью искомого числа R.


Например, для исходного числа 610 = 1102 результатом является число 10002 = 810, а для исходного числа 410 = 1002 результатом является число 11012 = 1310.


Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, большее 40. В ответе запишите это число в десятичной системе счисления.





Решение:

for n in range(1, 1000):
    s=format(n, 'b')
    if s.count('1')%2==0:
        s = s + '0'
        s = '10' + s[2:]
    else:
        s = s + '1'
        s = '11' + s[2:]
    r=int(s, 2)

    if r>40:
        print(n)

Здесь мы пишем программу, как было написано в уроке видеокурса ЕГЭ по информатике. Но, действительно, встречается и новый приём. Нужно изменить левые символы нашей строки s. Это можно сделать с помощью такой конструкции s[2:]. Таким образом, мы берём всю строку, кроме двух первых символов. Например, s='football', то s[2:] будет обозначать 'otball'.


Повторим основные идеи такого подхода при решении пятого задания из ЕГЭ по информатике с помощью программирования. Перебираем числа от 1 до 999 с помощью цикла for. В этом диапазоне надеямся найти наш ответ. С помощью команды format() превращаем число в строку уже в двоичной системе. Сумма цифр в строке зависит только от количества единиц. Нули ничего не дают в сумму. Поэтому применяем функцию .count. Дальше всё делаем, как написано в условии задачи. Команда int(s, 2) превращает строку в двоичной системе в число опять в десятичной системе счисления.


Ответ: 16

Демоверсия ЕГЭ по информатике 2023 (Задания 6-10)
Демоверсия ЕГЭ по информатике 2023 (Задания 11-15)
Демоверсия ЕГЭ по информатике 2023 (Задания 16-21)
Демоверсия ЕГЭ по информатике 2023 (Задания 22-27)








25-08-2022 в 14:56:38







Поддержать сайт:

Похожая статья:

Разбор демоверсии ОГЭ по информатике 2022. Часть 1

Привет! Сегодня посмотрим демонстрационный вариант ОГЭ по информатике ...

Категория: Информатика  Подкатегория: ОГЭ
Дата: 19-09-2021 в 07:02:08 8


Комментарии:

кхь
Альбина 28-02-2023 в 11:03:32



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.