Ёлка

Демоверсия ЕГЭ по информатике 2023 (Задания 11-15)



Продолжаем решать демоверсию ЕГЭ по информатике 2023.


Условия задач были взяты с сайта: https://fipi.ru/ege/demoversii-specifikacii-kodifikatory#!/tab/151883967-5


Видеокурс - это то, с чего лучше всего начать подготовку к ЕГЭ по информатике.



Демоверсия ЕГЭ по информатике 2023 (Задания 1-5)
Демоверсия ЕГЭ по информатике 2023 (Задания 6-10)
Демоверсия ЕГЭ по информатике 2023 (Задания 16-21)
Демоверсия ЕГЭ по информатике 2023 (Задания 22-27)





Задание 11

При регистрации в компьютерной системе каждому объекту присваивается идентификатор, состоящий из 250 символов и содержащий только десятичные цифры и символы из 1650-символьного специального алфавита. В базе данных для хранения каждого идентификатора отведено одинаковое и минимально возможное целое число байт. При этом используется посимвольное кодирование идентификаторов, все символы кодируются одинаковым и минимально возможным количеством бит.

Определите объём памяти (в Кбайт), необходимый для хранения 65 536 идентификаторов. В ответе запишите только целое число – количество Кбайт.


Решение:

Воспользуемся формулой для 11-ого задания из ЕГЭ по информатике.


ЕГЭ по информатике - задание 11 (Основная формула)

Вместо N подставляем число 1650 + 10 = 1660 (1650 символов плюс 10 цифр). Тогда


1660 < 211

Т.е. 11 бит точно хватит, чтобы закодировать 1650 символов.


В идентификаторе всего 250 ячеек. Найдём сколько будет "весить" один идентификатор: 250 * 11 = 2750 бит. Узнаем, сколько байт потребуется для одного идентификатора 2750 / 8 = 344 байт (округлили в большую сторону, чтобы точно хватило).


У нас всего 65536 идентификаторов. Тогда нам потребуется 65536 * 344 = 22544384 байт. Переведём в Кб: 22544384 / 1024 = 22016 Кб.


Ответ: 22016


Задание 12

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

    заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

    заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

Цикл

    ПОКА условие
      последовательность команд
    КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

    ЕСЛИ условие
      ТО команда1
      ИНАЧЕ команда2
    КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).


Дана программа для Редактора:

НАЧАЛО
ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>0)
  ЕСЛИ нашлось (>1)
    ТО заменить (>1, 22>)
  КОНЕЦ ЕСЛИ
  ЕСЛИ нашлось (>2)
    ТО заменить (>2, 2>)
  КОНЕЦ ЕСЛИ
  ЕСЛИ нашлось (>0)
    ТО заменить (>0, 1>)
  КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ




На вход приведённой выше программе поступает строка, начинающаяся с символа «>», а затем содержащая 39 цифр «0», n цифр «1» и 39 цифр «2», расположенных в произвольном порядке.

Определите наименьшее значение n, при котором сумма числовых значений цифр строки, получившейся в результате выполнения программы, является простым числом.


Решение:

Есть отличный разбор 12 задания в видеокурсе по подготовке к ЕГЭ по информатике.


Единица превращается в две двойки. Двойка преходим в саму себя. Ноль превращается в 1.


Изначально было 39 нулей. Значит, 39 единиц уже точно будет в строке, после выполнения программы. Так же там будет 39 двоек. Т.е., если не брать во внимание n единиц, сумма в результате будет 39 + 39 * 2 = 117.


Нужно прибавить некоторое количество чевёрок, чтобы получилось ближайшее простое число.


117 + 4*5 = 137.

Получается 5 единиц.


Ответ: 5



Задание 13

На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, И, К, Л. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.

Определите количество различных путей ненулевой длины, которые начинаются и заканчиваются в городе Е, не содержат этот город в качестве промежуточного пункта и проходят через промежуточные города не более одного раза.


Демоверсия ЕГЭ по информатике 2023 - Задание 13

Решение:

Решать будем примерно так же, как и классическую задачу. Основные идеи ни чем не отличаются.


ЕГЭ по информатике - задание 13 (Карта городов, решение)

В город Е входят города с числами: 16, 2 и 3. Значит, ответ получается 16 + 2 + 3 = 21.


Ответ: 21


Задание 14

Операнды арифметического выражения записаны в системе счисления с основанием 15.


123x515 + 1x23315

В записи чисел переменной x обозначена неизвестная цифра из алфавита 15-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 14. Для найденного значения x вычислите частное от деления значения арифметического выражения на 14 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.


Решение:

Решим с помощью программирования на языке Python.


for x in '0123456789ABCDE':
    r = int('123' + x + '5', 15) + int('1' + x + '233', 15)
    if r%14==0:
        print(r//14)
        break

Перебираем для переменной x все цифры в пятнадцатиричной системе. Вычисляем значение выражение. Функция int может перевести строку, записанную в пятнадцатиричной системе, в число.


Остаётся только найти нужное значение и остановить цикл с помощью break.


Ответ: 8767


Задание 15

Обозначим через ДЕЛ(n, m) утверждение "натуральное число n делится без остатка на натуральное число m". Для какого наименьшего натурального числа А формула

(ДЕЛ(x, 2) → ¬ДЕЛ(x, 3)) ∨ (x + A >= 100)

тождественно истинна (т.е. принимает значение 1) при любом натуральном значении переменной x ?



Решение:

Применим шаблон из видокурса ЕГЭ по информатике.


def D(n, m):
    if n%m==0: return True
    else: return False

for A in range(1, 1000):
    k=0
    for x in range(1, 10000):
        if (not(D(x, 2)) or not(D(x, 3))) or (x + A >= 100):
            k=k+1
    if k==9999:
        print(A)

Здесь в начале пишем функцию D, которая олицетворяет функцию ДЕЛ. Потом перебираем различные натуральные значения A. Если функция для какого-то значения сработает 9999 раз, то будем считать, что такое значение A нам подходит.


Самое маленькое значение получается 74.


Ответ: 94



Демоверсия ЕГЭ по информатике 2023 (Задания 1-5)
Демоверсия ЕГЭ по информатике 2023 (Задания 6-10)
Демоверсия ЕГЭ по информатике 2023 (Задания 16-21)
Демоверсия ЕГЭ по информатике 2023 (Задания 22-27)






27-08-2022 в 17:59:38





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2021 - Задание 27 (Заключительное)

Привет! Сегодня мы рассмотрим последнее 27 задание из ЕГЭ по информати...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 28-03-2021 в 20:51:02 3


Комментарии:

В решении к заданию 11 вы пишите: "У нас всего 4096 идетификаторов". Пожалуй, надо исправить на "65 536 идентификаторов"...
Игорь 29-11-2022 в 14:01:59

Исправил, спасибо!
Калужский Александр 29-11-2022 в 18:18:53

(Узнаем, сколько байт потребуется для одного идентификатора 2772 / 8 = 344 байт (округлили в большую сторону, чтобы точно хватило)) 2772 / 8 = 346,5 байт - там не 2772, а 2752 при делении которого получится ровно 344
Ярослав 23-07-2023 в 13:37:10

Спасибо, поправил!
Калужский Александр 23-07-2023 в 13:49:42



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.