вентилятор
Волк

Демоверсия ЕГЭ по информатике 2023 (Задания 6-10)



Продолжаем решать демоверсию ЕГЭ по информатике 2023.


Условия задач были взяты с сайта: https://fipi.ru/ege/demoversii-specifikacii-kodifikatory#!/tab/151883967-5


Напоминаю про видеокурс, который вы можете найти на этом сайте в открытом доступе. Это является мощным средством для подготовке к ЕГЭ по информатике 2023.


Демоверсия ЕГЭ по информатике 2023 (Задания 1-5)
Демоверсия ЕГЭ по информатике 2023 (Задания 11-15)
Демоверсия ЕГЭ по информатике 2023 (Задания 16-21)
Демоверсия ЕГЭ по информатике 2023 (Задания 22-27)





Задание 6

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n – целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Повтори 7 [Вперёд 10 Направо 120].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.


Решение:

Начертим фигуру, которую нарисует черепаха.


Реальный экзамен ЕГЭ по информатике 2022 - Задание 6 (Исполнитель черепаха)




Получается равносторонний треугольник.


От каждой точки на оси X, которая имеет целые координаты, можно провести перпендикуляр.


Реальный экзамен ЕГЭ по информатике 2022 - Задание 6 (Исполнитель черепаха)

Будет образовываться прямоугольный треугольник с углами 30° и 60°. Наша задача найти этот катет, который на рисунке обозначен пуктирной линией в целых числах для каждой точки оси Х с целыми координатами.


Для точки x1 (1; 0): L = 1 * tg(60°) ≈ 1 * 1,732.


Для точки x2 (2; 0): L = 2 * tg(60°) ≈ 2 * 1,732.


И т.д. Так мы можем дойти до середины стороны. Далее количество искомых точек будет повторяться, т.к. система симметрична.


Напишем программу на Python, которая подсчитает количество точек.


import math

s=0

for i in range(0, 5):
    s = s + int(i * math.tan(math.pi / 3))

s = 2*s

s = s + int(5 * math.tan(math.pi / 3))

print(s)

Переменная s отвечает за количество искомых точек. Проходим с 0-вой до 4-ой точки по оси X в цикле. Подсчитываем по формуле количество искомых точек. Координата X - это переменная i. Функция тангенса math.tan() принимает значения угла в радианах (60° = pi / 3).


Для точки x5 (5, 0) вычисляем количество искомых точек отдельно. Умножаем после цикла переменную s на 2, т.к. система симметрична.


Ответ: 38


Задание 7

Музыкальный фрагмент был записан в формате моно, оцифрован и сохранён в виде файла без использования сжатия данных. Размер полученного файла – 28 Мбайт. Затем тот же музыкальный фрагмент был записан повторно в формате стерео (двухканальная запись) и оцифрован с разрешением в 3,5 раза выше и частотой дискретизации в 2 раза меньше, чем в первый раз. Сжатие данных не производилось. Укажите размер полученного при повторной записи файла в Мбайт. В ответе запишите только целое число, единицу измерения писать не нужно.


Решение:

Общая формула для решения 7-ого задания на тему звуковых файлов из ЕГЭ по информатике.


ЕГЭ по информатике - задание 7 (Формула дискретизации)




Её легко запомнить. Объём записанного файла равен произведению всех остальных параметров. Важно соблюдать единицы измерения.


ЕГЭ по информатике - задание 7 (решение)

Вначале выписываем формулу для первого файла и для второго файла. Подставляем всё, что нам известно.


Для второго звукового файла коэффициенты все переносим в одну сторону.


Выражаем из первого уравнения произведение M * i * t и подставляем его во второе уравнение.


Ответ: 98



Задание 8

Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых только одна цифра 6, при этом никакая нечётная цифра не стоит рядом с цифрой 6.


Решение:

Решим с помощью программы. Об этом мы говорили в видеокурсе ЕГЭ по информатике.


k=0

for x1 in '1234567':
    for x2 in '01234567':
        for x3 in '01234567':
            for x4 in '01234567':
                for x5 in '01234567':
                    s = x1 + x2 + x3 + x4 + x5
                    if s.count('6')==1:
                        if s.count('16')==0 and s.count('61')==0 and s.count('36')==0 and s.count('63')==0 and s.count('56')==0 and s.count('65')==0 and s.count('76')==0 and s.count('67')==0:
                            k=k+1

print(k)


Ответ: 2961



Задание 9

Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке только одно число повторяется дважды;

– среднее арифметическое неповторяющихся чисел строки не больше суммы повторяющихся чисел.

В ответе запишите только число.


Скачать файлы

Решение:

Открываем файл Excel.

Если вы в первый раз встретились с задачей из 9 задания, рекомендую в начале ознакомиться с уроком из видеокурса по подготовке к ЕГЭ по информатике 2023.


В начале поработаем с первой строкой. Ячейка G1 будет показывать, есть ли ещё в этой строке число, которое находится в ячейке A1. Если есть, в ячейку G1 перенесём число из A1, иначе ставим 0. Т.к. числа натуральные, ноль не может попасться в виде числа в ячейке. Аналогично H1 будет выполнять ту же функцию для ячейки B1 и т.д.


Напишем формулу для G1:

=ЕСЛИ(ИЛИ(A1=B1;A1=C1;A1=D1;A1=E1;A1=F1);A1;0)

Аналогично и для H1, I1, J1, K1, L1.





Таким образом, нам будут подходить строчки, где 4 нуля в дополнительных ячейках. Распространим эти формулы на соответствующие столбцы.


В столбце М расставим количество нулей в каждой строчке. Пропишем для M1:


=СЧЁТЕСЛИ(G1:L1;"=0")

Распространим эту формулу на весь столбец.


В столбец N перенесём сумму повторяющихся чисел, но только там, где есть 4 нуля, иначе ноль. Напишем формулу для N1, распространим на весь столбец:


=ЕСЛИ(M1=4;СУММ(G1:L1);0)

Для этих же строчек, в столбце O разместим сумму неповторяющихся чисел. Пропишем в O1 и распространим на весь столбец:


=ЕСЛИ(M1=4;СУММ(A1:F1)-N1;0)

В столбце P расставим единицы на против тех строчек, которе удовлетворяют условию задачи. В P1:


=ЕСЛИ(И(M1=4; O1/4 <= N1);1;0)

Распространяем на весь столбец.


Выделим столбец P и внизу справа посмотрим сумму выделенных ячеек. Получается 2241.


Ответ: 2241



Задание 10

Текст произведения Льва Николаевича Толстого «Севастопольские рассказы» представлен в виде файлов различных форматов. Откройте один из файлов и определите, сколько раз встречается в тексте отдельное слово «теперь» со строчной буквы. Другие формы этого слова учитывать не следует.

В ответе запишите только число.


Скачать файлы

Решение:

Открываем соответствующий файл в программе Word. На вкладке "Главная" находится кнопка "Найти". Кликаем по чёрному треугольнику возле этой кнопки и выбираем "Расширенный поиск".

На вкладке "Главная" находится кнопка "Найти". Кликаем по чёрному треугольнику возле этой кнопки и выбираем "Расширенный поиск".


ЕГЭ по информатике - задание 10 (Расширенный поиск в текстовом редакторе)

Далее, нажимаем кнопку "Больше>>".


ЕГЭ по информатике - задание 10 (Расширенный поиск)

Теперь у нас есть все инструменты, чтобы решить 10 задание из ЕГЭ по информатике 2022.


В поле "Найти" пишем наше слово "солдаты". Галочку "Учитывать регистр" ставим, т.к. слово может быть только с маленькой буквы. Ставим галочку "Только слово целом".





Нажимаем Найти в -> "Основной документ".


ЕГЭ по информатике - задание 10 (Расширенный поиск)

Получаем ответ 45.


Ответ: 45 (Не сошлось с официальным ответом)

Демоверсия ЕГЭ по информатике 2023 (Задания 1-5)
Демоверсия ЕГЭ по информатике 2023 (Задания 11-15)
Демоверсия ЕГЭ по информатике 2023 (Задания 16-21)
Демоверсия ЕГЭ по информатике 2023 (Задания 22-27)








27-08-2022 в 07:19:26







Поддержать сайт:

Похожая статья:

ЕГЭ по информатике 2023 - Задание 23 (Чудо шаблон!)

Сегодня речь пойдёт о 23 задании из ЕГЭ по информатике 2023. Двадцать ...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 26-07-2022 в 08:30:14 3


Комментарии:

В задаче 6 указано, что черепаха направлена вдоль положительного направления оси ординат, а у Вас - в сторону положительного направления оси абсцисс. Незначительно в этой задаче, но может быть важно в другой.
Анон 27-09-2022 в 18:42:42

Да, перепутал оси
Калужский Александр 28-09-2022 в 21:14:29

В задание 10 не сошлось из-за того, что регистр НЕ НУЖЕН. Цитирую: «теперь» со строчной буквы. Другие формы этого слова учитывать не следует.. Т.е. регистр не нужен. И получится должно пятьдесят.
Никита 07-02-2023 в 17:17:41

Никита, если мы ставим галочку "учитывать регистр", как раз происходит поиск, как мы написали слово в поисковой строке.
Калужский Александр 07-02-2023 в 18:09:07



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.