Всемирный день риса

ЕГЭ по информатике ДЕМО 2024 - Задания 1-10



Привет! Вот и наступил новый учебный год 2024. И сегодня мы разберём ДЕМОверсию ЕГЭ по информатике 2024.


В этой статье будут разбираться задания с 1 по 10.


Ещё больше материалов для полной, качественной подготовки к ЕГЭ по информатике смотрите по ссылке на моём сайте CODE-ENJOY.


Вперёд к ПОБЕДЕ!





ЕГЭ по информатике ДЕМО 2024 - Задания 11-21
ЕГЭ по информатике ДЕМО 2024 - Задания 22-27


Задание 1

На рисунке изображена схема дорог N-ского района. В таблице звёздочкой обозначено наличие дороги из одного населённого пункта в другой. Отсутствие звёздочки означает, что такой дороги нет.


ЕГЭ по информатике ДЕМО 2024 - Задание 1

Каждому населённому пункту на схеме соответствует номер в таблице, но неизвестно, какой именно номер. Определите, какие номера в таблице могут соответствовать населённым пунктам E и F на схеме. В ответе запишите эти два номера в возрастающем порядке без пробелов и знаков препинания.


Решение:

Звёздочкой показан сам факт дороги (или её отсутствие) между городами.


Определим "особую точку". Это точка С, т.к. только эта точка имеет 6 дорог, а остальные имеют меньше дорог. Цифра 1 - это точка С.


Определим точки В и A. Это легко сделать, т.к. эти точки соединяются с точкой C и имеют по 2 дороге. По две дороге имеют цифры 2 и 6. Мы точно не можем узнать, где конкретно B, а где A. Просто знаем, что именно эти цифры занимают данные буквы. Цифры 7 и 4 соединяются помимо C (1) c цифрами 2 и 6. Значит, цифры 7 и 4 - это точки D и G (или G и D).


ЕГЭ по информатике ДЕМО 2024 - Задание 1 (решение)

Оставшееся цифры (3 и 5) - это как раз города E и F.


Данная задача отличается тем, что приходится действовать в условиях частичной неопределённости. Тем не менее, мы нашли искомые цифры для букв E и F, просто не знаем их точный порядок.


Нам в ответе нужно записать эти цифры в порядке возрастания. Ответ будет 35.


Ответ: 35



Задание 2

Миша заполнял таблицу истинности логической функции F


(x ∧ ¬y) ∨ (y ≡ z) ∨ ¬w,

но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.


ЕГЭ по информатике ДЕМО 2024 - Задание 2

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.


Решение:

Напишем шаблон на Питоне, о котором мы говорили в этой статье.


print('x y z w')
for x in range(0, 2):
    for y in range(0, 2):
        for z in range(0, 2):
            for w in range(0, 2):
                if not((x and not(y)) or (y==z) or not(w)):
                    print(x, y, z, w)

Получаем:


ЕГЭ по информатике ДЕМО 2024 - Задание 2 (Решение)

У нас есть столбец, где все единицы. Он может быть только на первом месте, т.к. в остальных столбцах есть нули. Значит, на первое место идёт w.


Есть столбец, где две единицы. Это может быть только третий столбец, т.к. во втором и четвёртом уже стоят по два нуля. Следовательно, в третьем столбце y.


Т.к. вторая и третья строчка не должны быть одинаковыми, то в пустующей ячейке в третьей строке будет стоять "1". Последняя строчка получается строка с тремя единицами. В этой строке ноль только у переменной z. Значит, переменная z на втором месте, а x на последнем.


Ответ: wzyx



Задание 3

В файле приведён фрагмент базы данных «Кондитерские изделия» о поставках конфет и печенья в магазины районов города. База данных состоит из трёх таблиц.


Таблица «Движение товаров» содержит записи о поставках товаров в магазины в течение первой половины июня 2023 г., а также информацию о проданных товарах. Поле Тип операции содержит значение Поступление или Продажа, а в соответствующее поле Количество упаковок, шт. внесена информация о том, сколько упаковок товара поступило в магазин или было продано в течение дня. Заголовок таблицы имеет следующий вид.


ЕГЭ по информатике ДЕМО 2024 - Задание 3 (условие 1)

Таблица «Товар» содержит информацию об основных характеристиках каждого товара. Заголовок таблицы имеет следующий вид.


ЕГЭ по информатике ДЕМО 2024 - Задание 3 (условие 2)

Таблица «Магазин» содержит информацию о местонахождении магазинов. Заголовок таблицы имеет следующий вид.


ЕГЭ по информатике ДЕМО 2024 - Задание 3 (условие 3)

На рисунке приведена схема указанной базы данных.


ЕГЭ по информатике ДЕМО 2024 - Задание 3 (условие 4)

Используя информацию из приведённой базы данных, определите общую массу (в кг) всех видов зефира, полученных магазинами на улице Металлургов за период с 4 по 13 июня включительно.


В ответе запишите только число.


Скачать файл




Решение:

Найдём артикулы товаров, которые связаны с зефиром.



Открываем вкладку "Товар", кликаем в ячейку F1, выбираем кнопку на вкладке "Главная" -> Сортировка и фильтр -> Фильтр.


Задание 3 досрочный ЕГЭ по информатике ДЕМО 2024 - решение через фильтры

Кнопка Фильтр может находится и на главной панели. Теперь можно отфильтровать товары, которые связаны с зефиром.


Задание 3 ЕГЭ по информатике ДЕМО 2024 - фильтруем товары, связанные с зефиром

Получаются номера артикулов: 4, 5, 6, 7.


Аналогично отфильтровываем магазины, которые находятся на улице Металлургов на вкладке "Магазин". Получаются номера ID: M2, M16.





После этого, переходим на вкладку "Движение товаров". Т.к. масса каждого товара, связанного с зефиром, различна (это можно посмотреть на вкладке "Товар" в столбце "Количество в упаковке"), то мы будем смотреть (фильтровать) каждый товар по очереди.


Отфильтруем нужные магазины. В начале отфильтруем товар с артикулом 4 и поставим Тип операции Поступление.


Задание 3 ЕГЭ по информатике ДЕМО 2024 - фильтруем товар c артикулом 4

Выделим ячейки из столбца "Количество упаковок" и справа внизу получим сумму упаковок товара с артикулом 4, которые были получены в нужных магазинах. Сумма равна 1400.


Важно: Когда используем фильтры, мы не можем пользоваться функцией =СУММ().


В одной упаковке данного товара 250 г. Найдём массу полученного товара:


1400 * 0,25 кг = 350 кг

Аналогично делаем для оставшихся товаров с артикулами 5, 6, 7.


Для артикула 5:


1400 * 0,8 кг = 1120 кг

Для артикула 6:


1400 * 0,5 кг = 700 кг

Для артикула 7:


1400 * 1 кг = 1400 кг

Найдём общую сумму:


350 кг + 1120 кг + 700 кг + 1400 кг = 3570 кг

Даты в этой задачи трогать не нужно, т.к. все дни подходят.


Ответ: 3570



Задание 4

По каналу связи передаются сообщения, содержащие только восемь букв: А, Б, В, Г, Д, Е, Ж и З. Для передачи используется двоичный код, удовлетворяющий условию Фано.


Кодовые слова для некоторых букв известны:


ЕГЭ по информатике ДЕМО 2024 - Задание 4


Какое наименьшее количество двоичных знаков потребуется для кодирования двух оставшихся букв?


В ответе запишите суммарную длину кодовых слов для букв: Ж, З.


Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.





Решение:

Здесь речь идёт об условии Фано, поэтому мы можем применить приём дерево ФАНО. Об этом приёме Вы можете почитать на моём сайте в соответствующей статье. Расставим на дереве фано уже известные буквы.


ЕГЭ по информатике ДЕМО 2024 - Задание 4 (решение)



Для двух оставшихся букв идеально подходят коды: 11 и 100. Это и будет минимальная длина для двух букв.


ЕГЭ по информатике ДЕМО 2024 - Задание 4 (решение 2)


Сумма двух букв двоичных знаков будет равна:


2 + 3 = 5

Ответ: 5



Задание 5

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.


1. Строится двоичная запись числа N.

2. Далее эта запись обрабатывается по следующему правилу:


а) если число N делится на 3, то к этой записи дописываются три последние двоичные цифры;

б) если число N на 3 не делится, то остаток от деления умножается на 3, переводится в двоичную запись и дописывается в конец числа.


Полученная таким образом запись является двоичной записью искомого числа R.


3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 12 = 11002 результатом является число 11001002 = 100, а для исходного числа 4 = 1002 это число 100112 = 19. Укажите минимальное число R, большее 151, которое может быть получено с помощью описанного алгоритма. В ответе запишите это число в десятичной системе счисления.


Решение:

Подобные задачи из 5 задания подробнейшим образом рассматривались в цикле статей по подготовке к ЕГЭ по информатике.


mn = 10**10
for n in range(4, 1000):
    s = format(n, 'b')
    if n%3==0:
        s = s + s[-3] + s[-2] + s[-1]
    else:
        s = s + format((n%3)*3, 'b')

    r = int(s, 2)
    if r > 151:
        mn = min(r, mn)

print(mn)

Получается ответ 163. Мы здесь начинаем перебирать числа с 4, т.к. только ≥ 4 числа в двоичной системе имеют минимум три разряда. Это позволяет нам взять последние 3 цифры.


Программа получает r то большие, то маленькие. Чтобы найти наименьшее значение r применяем приём "Царь горы".


Ответ: 163



Задание 6

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n – целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.


Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.


Черепахе был дан для исполнения следующий алгоритм:


Повтори 7 [Вперёд 10 Направо 120].


Определите, сколько точек с целочисленными координатами будут находиться внутри области, которая ограничена линией, заданной этим алгоритмом. Точки на линии учитывать не следует.



Решение:

Как решать 6 задание из ЕГЭ по информатике с лёгкостью мы говорили в этой статье.


Решим с помощью программы Кумир.


Запустим программу Кумир-Стандарт. В начале нужно подключить модуль Черепаха.


ЕГЭ по информатике 2023 - Задание 6 (Настройка программы Кумир-Стандарт)




Перепишем программу:


использовать Черепаха
алг
нач
  опустить хвост
  нц 7 раз
    вперед(10)
    вправо(120)
  кц
кон

В появившемся окне необходимо выставить масштаб на 1.


ЕГЭ по информатике ДЕМО 2024 - Задание 6 (Настраиваем масштаб)

Программа нарисует треугольник.


ЕГЭ по информатике ДЕМО 2024 - Задание 6 (Решение)

Количество точек с целочисленными координатами, которые не лежат на линиях, равно 38.


Ответ: 38



Задание 6 (второй вариант)

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n – целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n – целое число), вызывающая передвижение в противоположном голове направлении; Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке, Налево m (где m – целое число), вызывающая изменение направления движения на m градусов против часовой стрелки. Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.


Черепахе был дан для исполнения следующий алгоритм:


Повтори 2 [Вперёд 8 Направо 90 Вперёд 18 Направо 90]
Поднять хвост
Вперёд 4 Направо 90 Вперёд 10 Налево 90
Опустить хвост
Повтори 2 [Вперёд 17 Направо 90 Вперёд 7 Направо 90]

Определите, сколько точек с целочисленными координатами будут находиться внутри объединения фигур, ограниченного заданными алгоритмом линиями, включая точки на линиях.





Решение:

Эта задача решается аналогично предыдущей. Напишем программу в Кумире:


использовать Черепаха
алг
нач
  опустить хвост
  нц 2 раз
    вперед(8)
    вправо(90)
    вперед(18)
    вправо(90)
  кц
  поднять хвост
  вперед(4)
  вправо(90)
  вперед(10)
  влево(90)
  опустить хвост
  нц 2 раза
    вперед(17)
    вправо(90)
    вперед(7)
    вправо(90)
  кц
кон

Получается две фигуры.


ЕГЭ по информатике ДЕМО 2024 - Задание 6 (Решение 2)

Здесь просят посчитать точки с целыми координатами, которые находятся в объединении двух фигур. На линиях тоже точки нужно учитывать. Лучше всего использовать умножение (почитать сколько в ряду точек и умножить на количество рядов).


Ответ: 275



Задание 7

Прибор автоматической фиксации нарушений правил дорожного движения делает цветные фотографии размером 1024×768 пикселей, используя палитру из 4096 цветов. Для передачи снимки группируются в пакеты по 256 штук. Определите максимальный размер одного пакета фотографий в Мбайт.


В ответе запишите только число.


Решение:

Найдём сколько бит занимает одна точка фотографии по формуле:


ЕГЭ по информатике - задание 7 (Формула)

ЕГЭ по информатике - задание 7 (Вес точки)

Получается 12 бит весит одна точка.





ЕГЭ по информатике - задание 7 (Изображение)

Узнаем, сколько весит одна фотография. Нужно количество точек умножить на вес одной точки.


V1 = 1024 * 768 * 12 бит = 9437184 бит

Узнаем, сколько будет весит пакет из 256 фотографий.


V = 9437184 бит * 256 = 2415919104 бит

Переведём это число в Мб.


V = 2415919104 бит / (8 * 1024 * 1024) = 288 Мб

Этот ответ не совпадает с официальным, но совпадает с ответом других преподавателей.


Ответ: 288



Задание 8

Сколько существует восьмеричных пятизначных чисел, не содержащих в своей записи цифру 1, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом?


Решение:

На моём сайте есть невероятная статья, как решать 8 задание чисто на Питоне.


k=0
for x1 in '1234567':
    for x2 in '01234567':
        for x3 in '01234567':
            for x4 in '01234567':
                for x5 in '01234567':
                    s = x1 + x2 + x3 + x4 + x5
                    if s.count('1')==0:
                        if s.count(x1)==1 and s.count(x2)==1 and s.count(x3)==1 and s.count(x4)==1 and s.count(x5)==1:
                            if x1 in '0246' and x2 in '1357' and x3 in '0246' and x4 in '1357' and x5 in '0246':
                                k=k+1
                            if x1 in '1357' and x2 in '0246' and x3 in '1357' and x4 in '0246' and x5 in '1357':
                                k=k+1

print(k)

Ответ: 180



Задание 9

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия:


– в строке есть два числа, каждое из которых повторяется дважды, остальные три числа различны;


– среднее арифметическое всех повторяющихся чисел строки меньше среднего арифметического всех её чисел.


В ответе запишите только число.


Скачать файл

Решение:

В ячейке H1 пропишем формулу:


=СЧЁТЕСЛИ($A1:$G1;A1)

Получим число 2. Т.к. в этой строчке повторяется число A1 два раза.


ЕГЭ по информатике ДЕМО 2024 - Задание 9

Растянем эту формулу вправо на 7 ячеек. Мы закрепили в формуле столбцы в диапазоне с помощью знака $, чтобы сам диапазон не смещался. После этого программа выдаст четыре двойки (остальные будут единицы), т.к. в этой строчке два различных числа повторяются два раза.


Чтобы строчка подходила под первое условие, у нас должно получатся четыре двойки и три единицы.


Распространим эту формулу на всё пространство.


ЕГЭ по информатике ДЕМО 2024 - Задание 9 (Распространяем формулу)






Подсчитаем количество двоек для каждой строчки. Напишем формулу в ячейке O1:


=СЧЁТЕСЛИ(H1:N1; 2)

Распространим формулу на весь столбец. Если в столбце O будет 4, значит, два числа повторяются два раза.


Проверим, чтобы остальные числа были различны.


В ячейке P1 пропишем похожую формулу:


=СЧЁТЕСЛИ(H1:N1; 1)

Распространяем формулу на весь столбец. Если в столбце P будет число 3, значит, остальные числа различны.


Можно сказать, теперь есть данные, чтобы проверить первое условие.


Чтобы проверить второе условие, воспользуемся интересной функцией =СУММЕСЛИМН(). В ячейке Q1 напишем:


=СУММЕСЛИМН(A1:G1;H1:N1;2)

Первый параметр - это диапазон откуда берём числа для суммирования, второй параметр - диапазон, где указано, нужно ли суммировать то или иное число (критерий суммирования). Третий параметр - это то число, которое сигнализирует, что число подлежит суммированию. Это число программа ищет в диапазоне критерия. Таким образом, мы найдём сумму повторяющихся чисел. Для первой строчки число получается 228.


Чтобы найти среднее арифметическое этих чисел, нужно разделить эту сумму на 4.


Получается такая формула:


=СУММЕСЛИМН(A1:G1;H1:N1;2)/4

Распространяем данную формулу на весь столбец Q.


Чтобы найти среднее арифметическое всех чисел, нужно сумму разделить на количество.


В ячейке R1 пропишем формулу:


=СУММ(A1:G1)/7

Расставим 1 напротив тех строчек, которые подходят по второму условию. В ячейке S1 пропишем:





=ЕСЛИ(Q1<R1;1;0)

Распространим формулу на весь столбец S.


Осталось расставить 1 напротив тех строчек, которые удовлетворяют двум условиям задачи.


В ячейке T1 пропишем формулу:


=ЕСЛИ(И(O1=4;P1=3;S1=1);1;0)

Ячейка O1, отвечает, чтобы два различных числа повторялись два раза. Ячейка P1 отвечает, чтобы три других числа были различны. Ячейка S1 отвечает, чтобы выполнялось второе условие.


Распространяем эту формулу на столбец T и смотрим внизу справа сумму данного столбца. Ответ получается 83.


Ответ: 83



Задание 10

Определите, сколько раз в тексте главы II повести А.И. Куприна «Поединок» встречается сочетание букв «все» или «Все» только в составе других слов, но не как отдельное слово. В ответе укажите только число.


Скачать файл

Решение:

Скопируем текст из 2-ой главы в новый Word-документ.


Найдём, сколько раз встречаются сочетания букв "все" или "Все" в тексте нового документа.


На вкладке "Главная" находится кнопка "Найти". Кликаем по чёрному треугольнику возле этой кнопки и выбираем "Расширенный поиск".



ЕГЭ по информатике - задание 10 (Расширенный поиск в текстовом редакторе)

Далее, нажимаем кнопку "Больше>>".


ЕГЭ по информатике - задание 10 (Расширенный поиск)




Теперь у нас есть все инструменты, чтобы решить 10 задание из ЕГЭ по информатике.


В поле "Найти" пишем наше слово "все".


Нажимаем Область поиска -> "Основной документ".


ЕГЭ по информатике - задание 10 (Решение)

Получилось 17 совпадений.




Теперь найдём, сколько отдельных слов "все" или "Все" в тексте. Поставим галочку Только слово целиком.


Нажимаем область поиска -> "Основной документ".


Получается 8 совпадений.


Чтобы ответить на вопрос задачи нужно из 17 вычесть 8.


17 - 8 = 9

Ответ: 9

ЕГЭ по информатике ДЕМО 2024 - Задания 11-21
ЕГЭ по информатике ДЕМО 2024 - Задания 22-27




25-08-2023 в 18:48:11





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2023 - Задание 25 (Делимость чисел)

Всем привет! Добрались мы до 25 задания из ЕГЭ по информатике 2023. Ра...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 04-08-2022 в 09:36:45 1



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.