Ёлка

ЕГЭ по информатике 2022 - Задание 12 (Вперёд, к Победе!)



Сегодня научимся решать 12 задание из ЕГЭ по информатике 2022.


В основном 12 задание решается шаблонно с помощью Питона, но есть и задачи, в которых нужен особый подход.


Перейдём к классической задачке из ЕГЭ по информатике 2022.





Задача (Классическая)

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.


1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Если цепочки v в строке нет, эта команда не изменяет строку. Вторая команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Дана программа для исполнителя Редактор:


НАЧАЛО
ПОКА нашлось (2222) ИЛИ нашлось (666)
  ЕСЛИ нашлось (2222)
    ТО заменить (2222, 6)
    ИНАЧЕ заменить (666, 2)
  КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ

Какая строка получится в результате применения приведённой выше программы к строке, состоящей из 239 идущих подряд цифр 6? В ответе запишите полученную строку.





Решение:

Решим задачу с помощью программы на Python'е.


s = '6'*239

while ('2222' in s) or ('666' in s):
    if '2222' in s:
        s = s.replace('2222', '6', 1)
    else:
        s = s.replace('666', '2', 1)

print(s)

Здесь в начале формируется строка, состоящая из 239 шестёрок. Потом эта строка подаётся в программу. Программу переводим с русского языка на язык Питон.


Третий параметр в функции replace обозначает, что замену нужно производить один раз. Это в точности соответствует предложенной функции заменить.


Ответ получается 2266.


Ответ: 2266



В следующей типовой задаче из ЕГЭ по информатике 2022 нужно сообразить один момент.


Задача (Нужно сообразить)

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.


1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w, вторая проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Дана программа для исполнителя Редактор:


НАЧАЛО
  ПОКА нашлось (21) ИЛИ нашлось (31) ИЛИ нашлось (23)
    ЕСЛИ нашлось (21)
      ТО заменить (21, 12)
    КОНЕЦ ЕСЛИ
    ЕСЛИ нашлось (31)
      ТО заменить (31, 13)
    КОНЕЦ ЕСЛИ
    ЕСЛИ нашлось (23)
      ТО заменить (23, 32)
    КОНЕЦ ЕСЛИ
  КОНЕЦ ПОКА
КОНЕЦ

На вход приведённой ниже программе поступает строка, содержащая 50 цифр 1, 50 цифр 2 и 50 цифр 3, расположенных в произвольном порядке. Запишите без разделителей символы, которые имеют порядковые номера 10, 90 и 130 в получившейся строке.





Решение:

Здесь сказали, что начальный порядок цифр в строке неизвестен. А просят написать конкретные данные на выходе. Отсюда делаем вывод, что любой порядок в начале приводит к одному и тому же результату.


В строке заведём цифры по порядку: в начале единицы, потом двойки, потом тройки.


s = '1'*50 + '2'*50 + '3'*50

while ('21' in s) or ('31' in s) or ('23' in s):
    if '21' in s:
        s = s.replace('21', '12', 1)
    if '31' in s:
        s = s.replace('31', '13', 1)
    if '23' in s:
        s = s.replace('23', '32', 1)

print(s[9] + s[89] + s[129])

Чтобы обратится к конкретному символу в строке, используем конструкцию s[позиция символа]. Но нумерация начинается с нуля.


В ответе запишем 132.


Ответ: 132



В следующей примерной задаче из ЕГЭ по информатике 2022 опять используем Питон.


Задача (Снова программируем)

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.



1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Если цепочки v в строке нет, эта команда не изменяет строку. Вторая команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Дана программа для исполнителя Редактор:


НАЧАЛО
ПОКА нашлось (111)
  заменить (111, 22)
  заменить (222, 11)
КОНЕЦ ПОКА
КОНЕЦ

Известно, что исходная строка содержала более 70 единиц и не содержала других цифр. Укажите минимально возможную длину исходной строки, при которой в результате работы этой программы получится строка, содержащая максимально возможное количество единиц.





Решение:

Здесь мы попробуем с помощью программы формировать строчки с разной длиной и смотреть, какое количество единиц получится на выходе.


for i in range(71, 1000):
    s = '1'*i
    while '111' in s:
        s = s.replace('111', '22', 1)
        s = s.replace('222', '11', 1)

    print(i, s.count('1'))

Посмотрев результаты, понимаем, что максимальное количество единиц в окончательной строке равно 4. А минимальное количество единиц в изначальной строке, чтобы получилось в итоге 4 единицы, равно 73.


Ответ: 73



Ещё один частый гость в тренировочных вариантах из ЕГЭ по информатике 2022.


Задача (Сумма цифр + непонятный символ)

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.



1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w, вторая проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Дана программа для исполнителя Редактор:


НАЧАЛО
  ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>3)
    ЕСЛИ нашлось (>1)
      ТО заменить (>1, 22>)
    КОНЕЦ ЕСЛИ
    ЕСЛИ нашлось (>2)
      ТО заменить (>2, 2>1)
    КОНЕЦ ЕСЛИ
    ЕСЛИ нашлось (>3)
      ТО заменить (>3, 1>2)
    КОНЕЦ ЕСЛИ
  КОНЕЦ ПОКА
КОНЕЦ

На вход приведённой ниже программе поступает строка, начинающаяся с символа «>», а затем содержащая 28 цифр 1, 18 цифр 2 и 35 цифр 3, расположенных в произвольном порядке. Определите сумму числовых значений цифр строки, получившейся в результате выполнения программы. Так, например, если результат работы программы представлял бы собой строку, состоящую из 50 цифр 4, то верным ответом было бы число 200.





Решение:

Здесь снова результат будет одним и тем же независимо от того, как будут расположены числа в начале.


s = '>' + '1'*28 + '2'*18 + '3'*35

while ('>1' in s) or ('>2' in s) or ('>3' in s):
    if '>1' in s:
        s = s.replace('>1', '22>', 1)
    if '>2' in s:
        s = s.replace('>2', '2>1', 1)
    if '>3' in s:
        s = s.replace('>3', '1>2', 1)

# Находим сумму цифр в строке
sm=0
for i in range(0, len(s)):
    if s[i]!='>':
        sm = sm + int(s[i])
        
print(sm)

Чтобы найти сумму цифр, мы пробегаем по всей строке с помощью цикла range. Если символ не равен ">", то превращаем его в число с помощью функции int() и суммируем в переменную sm.


Получается 465.


Так же можно сумму цифр найти с помощью такой конструкции: sm = s.count('1')*1 + s.count('2')*2 + s.count('3')*3. Других цифр, кроме 1, 2 и 3 нет в строке. Мы находим вклад каждой цифры в зависимости от её веса и количества.


Ответ: 465



Задача (Трудно запрограммировать)

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.


1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w, вторая проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Дана программа для исполнителя Редактор:


НАЧАЛО
  ПОКА нашлось (11)
    ЕСЛИ нашлось(112)
      ТО заменить (112, 5)
      ИНАЧЕ заменить (11, 3)
  КОНЕЦ ПОКА
КОНЕЦ

Исходная строка содержит 23 единицы и 5 двоек, других цифр нет, точный порядок расположения цифр неизвестен. Какую наибольшую сумму цифр может иметь строка, которая получится после выполнения программы?





Решение:

Здесь не важно, по какой ветке будет идти программа, прирост в сумме цифр будет всегда равен 1. Поэтому можно расположить в начале только 1, а затем все двойки в исходной строке.


Одиннадцать раз символы '11' превратятся в '3'. Тогда 11 * 3 = 33. Останутся цифры '122222'. Их сумма равна 11.


В ответе получается 33 + 11 = 44.


Ответ: 44



Задача (Крепкий орешек)

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.


1. заменить (v, w)
2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w, вторая проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Дана программа для исполнителя Редактор:


НАЧАЛО
  ПОКА нашлось (01) или нашлось (02)
    заменить (01, 2202)
    заменить (02, 10)
  КОНЕЦ ПОКА
КОНЕЦ

Известно, что начальная строка начиналась с нуля, а далее содержала только единицы и двойки. После выполнения данной программы получилась строка, содержащая 40 единиц и 64 двойки. Сколько двоек было в исходной строке ?





Решение:

Посмотрим, во что превращается 1:


01 -> 2202 -> 2210

Посмотрим, во что превращается 2:


02 -> 10

Т.е. в окончательном результате двойки могли возникнуть только из 1. Двоек получается в два раза больше, чем было изначально единиц.


Получается, что изначальное количество единиц равно 64 / 2 = 32. Эти 32 единицы так же принесли 32 единицы. Всего 40 единиц стало. Значит, ещё 8 единиц получилось в результате преобразования 02 -> 10. Т.е. двоек будет 8.


Теперь попробуем решить задачу с помощью программы. Здесь неизвестно количество единиц и двоек. Поэтому придётся создавать вложенные циклы. Предположим, что количество единиц и двоек меньше 100, чтобы программа отработала за адекватное время.


for i in range(1, 100):
    for j in range(1, 100):
        
        s = '0' + '1'*i + '2'*j

        while ('01' in s) or ('02' in s):
            s = s.replace('01', '2202', 1)
            s = s.replace('02', '10', 1)

        if s.count('1')==40 and s.count('2')==64:
            print(j)

Получается количество двоек равно восьми.


Ответ: 8



Решим задачу про Робота, которая в последнее время редко встречается на экзамене по информатике.


Задача (Робот)

Система команд исполнителя РОБОТ, «живущего» в прямоугольном лабиринте на клетчатой плоскости, состоит из 8 команд. Четыре команды - это команды-приказы:


вверх вниз влево вправо

При выполнении любой из этих команд РОБОТ перемещается на одну клетку соответственно: вверх , вниз , влево , вправо .


Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится РОБОТ:


сверху свободно снизу свободно слева свободносправа свободно

Цикл
   ПОКА условие
       последовательность команд
   КОНЕЦ ПОКА
выполняется, пока условие истинно.
В конструкции
ЕСЛИ условие
    ТО команда1
    ИНАЧЕ команда2
КОНЕЦ ЕСЛИ
выполняется команда1 (если условие истинно) или команда2 (если условие ложно)

В конструкциях ПОКА и ЕСЛИ условие может содержать команды проверки, а также слова И, ИЛИ, НЕ, обозначающие логические операции.


Если РОБОТ начнёт движение в сторону находящейся рядом с ним стены, то он разрушится и программа прервётся.


Сколько клеток лабиринта соответствуют требованию, что, начав движение в ней и выполнив предложенную программу, РОБОТ уцелеет и остановится в закрашенной клетке (клетка F6)?


НАЧАЛО
  ПОКА снизу свободно ИЛИ справа свободно
    ПОКА справа свободно
        вправо
    КОНЕЦ ПОКА
    ЕСЛИ снизу свободнo
        ТО вниз
    КОНЕЦ ЕСЛИ
  КОНЕЦ ПОКА
КОНЕЦ
ЕГЭ по информатике 2021 - задание 12 (Лабиринт, где живёт Робот)




Решение:

Проанализируем внимательно программу для Робота.


В программе есть главный цикл, внутри цикла проверяется сначала возможность двигаться вправо. Если есть такая возможность, робот будет двигаться до упора с помощью ещё одного цикла. Потом после того как больше нет возможности двигаться вправо, с помощью основного цикла и записанного условия будет перемещаться вниз, пока есть такая возможность.


Если нет возможности двигаться ни вправо, ни вниз, то Робот завершает программу.


Поняв этот алгоритм не сложно отметить те клетки, стартовав с которых, Робот остановится на клетке F6.


ЕГЭ по информатике 2021 - задание 12 (клетки лабиринта соответствуют требованию)

Ещё раз, Робот до упору будет двигаться вправо, потом до упору вниз, насколько это возможно. Вот алгоритм в двух словах.



Важно в этих задачах простыми словами сформулировать алгоритм, чтобы можно было проверять целые блоки лабиринта.


Количество клеток, удовлетворяющие условию будет 21.


Ответ: 21



12 Задание из ЕГЭ по информатике 2021 выглядит обычно объёмным, но на деле описываются обычные конструкции (Циклы и условия), которые есть в большинстве языках программирования.


Задача (Чертёжник)

Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнить команду сместиться на(a, b), где a, b - целые числа. Эта команда перемещает Чертёжника из точки с координатами (x, y) в точку с координатами (x + a, y + b).


Например, если Чертёжник находится в точке с координатами (4, 2), то команда сместиться на(2, -3) переместит Чертёжника в точку (6, -1).


Цикл
ПОВТОРИ число РАЗ
последовательность команд
КОНЕЦ ПОВТОРИ

означает, что последовательность команд будет выполнена указанное число раз (число должно быть натуральным).


Чертёжнику был дан для исполнения следующий алгоритм (число повторений и величины смещения в первой из повторяемых команд неизвестны):

НАЧАЛО
сместиться на(8, -60)
  ПОВТОРИ ... РАЗ
    сместиться на(..., ...)
    сместиться на(4, -6)
  КОНЕЦ ПОВТОРИ
сместиться на(-35, -3)
КОНЕЦ

В результате выполнения этого алгоритма Чертёжник возвращается в исходную точку. Какое наибольшие число повторений могло быть указано в конструкции "ПОВТОРИ ... РАЗ" ?





Решение:

Эта задача похоже на задачу Кузнечик, которую рассматривали в 5 задании.


Напишем для переменной x уравнение.


8 + n * x + n * 4 - 35 = 0

Всё выражение приравниваем к нулю, т.к. Чертёжник возвращается в исходную точку, т.е. как ни ходил Чертёжник, он никуда в итоге не сдвинулся.


n - положительное целое число, количество повторений.


x - целое число, смещение по координате x.



n * x + n * 4 = 27

n * ( x + 4 ) = 27

Нужно подобрать x и n, чтобы равенство было верным.


Число n может быть 27, 9, 3, 1. Нам нужно выбрать число n, как можно больше.


Проверим число 27! Тогда выражение x + 4 = 1 => x = -3. Теперь нужно проверить это число для координаты y.


-60 + n * y - n * 6 - 3 = 0

27 * y - 27 * 6 = 63

27 * ( y - 6 ) = 63

Видим, что нельзя подобрать такое целое число для 27, чтобы при умножении получалось 63.


Проверим число 9! Тогда выражение x + 4 = 3 => x = -1. Теперь нужно проверить это число для координаты y.


-60 + n * y - n * 6 - 3 = 0

9 * y - 9 * 6 = 63

9 * ( y - 6 ) = 63

Видим, что можно подобрать такое целое число для 9, чтобы при умножении получалось 63. Это число 7. Значит, y - 6 = 7 => y = 13


Мы подобрали все нужные числа и нашли наибольшее число n=9.


Ответ: 9



Счастливых экзаменов по информатике!








19-11-2021 в 09:06:18





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2021 - Задание 25 (Обработка целочисленной информации)

Всем привет! Пришло время разбора 25 задания из ЕГЭ по информатике 202...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 12-01-2021 в 15:11:32 9


Комментарии:

почему 5-ую задачу сложно запрограммировать? тут ведь тоже произвольный порядок я пробовал в программе ставить сначала единицы, а потом двойки и наоборот - сначала двойки а потом единицы печатаю s и суммирую цифры получается везде 44
тектс 22-12-2021 в 08:30:55

Если бы сама программа была немного другая, то могло и не получится. Т.е. тут нужно самостоятельно провести анализ, при каком расположении цифр сумма будет максимальной.
Калужский Александр 22-12-2021 в 08:42:07

хорошо, спасибо
тектс 22-12-2021 в 09:20:21

Обожаю ваш сайт! Спасибо за пояснение усложненных задач.
Миса 09-06-2022 в 09:08:44



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.