Ёлка

Разбор демоверсии ЕГЭ по информатике 2022 (6-10 Задание)



Продолжаем разбор демонстрационного варианта ЕГЭ по информатике 2022.


В этой статье разберём с 6-ого по 10 задание.


Источник задач: https://fipi.ru/ege/demoversii-specifikacii-kodifikatory#!/tab/151883967-5


Удачи на ЕГЭ по информатике 2022!



Разбор демоверсии ЕГЭ по информатике 2022 (1-5 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (11-15 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (16-21 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (22-27 Задание)

Задание 6

Определите, при каком наибольшем введённом значении переменной s программа выведет число 64. Для Вашего удобства программа представлена на четырёх языках программирования.


ПаскальPythonАлгоритмический язык
var s, n: integer;
begin
  readln(s);
  s := s div 10;
  n := 1;
  while s < 51 do
  begin
    s := s + 5;
    n := n * 2
  end;
  writeln(n)
end.
s = int(input())
s = s // 10
n = 1
while s < 51:
  s = s + 5
  n = n * 2
print(n)
алг
нач
  цел n, s
  ввод s
  s := div(s, 10)
  n := 1
  нц пока s < 51
    s := s + 5
    n := n * 2
  кц
  вывод n
 кон
C++
#include 
using namespace std;
int main()
{ 
  int s, n;
  cin >> s;
  s = s / 10;
  n = 1;
   while (s < 51) { s = s + 5; n = n * 2; }
  cout << n << endl;
  return 0;
}


Решение:

Решим задачу методом перебора на языке программирования Python.


Нас спрашивают, какое наибольшее число должен ввести пользователь программы, чтобы программа распечатала число 64. Мы будем подставлять каждое число в диапазоне, к примеру, от 1 до 1000 и попробуем получить на выходе число 64.


for i in range(1, 1000):
  s = i
  s = s // 10
  n = 1
  while s < 51:
      s = s + 5
      n = n * 2
  if n==64: print(i)

Делаем это с помощью цикла. Как только в переменной n будет значение 64, мы печатаем переменную i


...
251
252
253
254
255
256
257
258
259
>>>

Видим, что максимальное число, которое даёт нужный результат это 259.


Ответ: 259.

Смотреть 6 Задание на YouTube




Задание 7

Для хранения произвольного растрового изображения размером 128 × 320 пикселей отведено 20 Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?


Решение:
ЕГЭ по информатике 2022 - задание 7 (изображение размером 128 на 320)

Узнаем, сколько информации будет весить один пиксель (одна точка).


ЕГЭ по информатике 2022 - задание 7 (демонстрационный вариант, решение)

Теперь воспользуемся главной формулой для 7 задания из ЕГЭ по информатике.


ЕГЭ по информатике - задание 7 (Формула)


ЕГЭ по информатике - задание 7 (Формула)

Ответ: 16

Смотреть 7 Задание на YouTube



Задание 8

Все четырёхбуквенные слова, в составе которых могут быть только буквы Л, Е, М, У, Р, записаны в алфавитном порядке и пронумерованы, начиная с 1.

Ниже приведено начало списка.


1. ЕЕЕЕ
2. ЕЕЕЛ
3. ЕЕЕМ
4. ЕЕЕР
5. ЕЕЕУ
6. ЕЕЛЕ

Под каким номером в списке идёт первое слово, которое начинается с буквы Л?


Решение:

Закодируем в правом столбце буквы цифрами, начиная с нуля.


ЕГЭ по информатике 2022 - задание 8 (Кодируем буквы)

Дальше кодирование прекращаем, т.к. буквы начинают повторяться.


Если представить список в виде цифр, то получится счёт в пятеричной системе, ведь у нас пять цифр.


1. 0000
2. 0001
3. 0002
4. 0003
5. 0004
6. 0010

В вопросе спрашивают про первое слово, которое начинается с буквы Л. А мы понимаем, что спрашивают про число 10005 в пятеричной системе, потому что это первое число, которое начинается с 1. Длина числа равна 4, т.к. длина слов равна 4.


Переведём число 10005 из пятеричной системы в нашу родную десятичную систему.


0*50 + 0*51 + 0*52 + 1*53 = 125

А порядковый номер (столбец слева) отличается от счёта в пятеричной системе на 1. Порядковый номер на 1 больше. Поэтому в ответе напишем 126.


Ответ: 126

Смотреть 8 Задание на YouTube




Задание 9

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Выясните, какое количество троек чисел может являться сторонами треугольника, то есть удовлетворяет неравенству треугольника.

В ответе запишите только число.



Скачать файлы


Решение:

Неравенство треугольника заключается в том, что каждая сторона должна быть меньше, чем сумма двух других сторон.


Напротив тех строчек, которые удовлетворяют этому неравенству будем ставить 1, остальным ставим 0.


Сформируем формулу для первой строчки. Кликаем в ячейку D1 и нажимаем кнопку Вставить функцию.


ЕГЭ по информатике 2022 - задание 9 (Кнопка вставить функцию)

Выбираем функцию ЕСЛИ. Пишем логическое выражение:


И(A1

В Значение_если_истина ставим 1. В Значение_если_ложь ставим 0.


ЕГЭ по информатике 2022 - задание 9 (Формула)

Если одновременно выполняются три условия, то в ячейку идёт 1, иначе 0.


Распространим формулу на весь столбец. Подведём курсор к правому нижнему углу. Как только загорелся чёрный крестик, кликаем два раза, и формула должна распространится на весь столбец.


Возле тех строчек, которые удовлетворяют условию, будут нули, возле тех, которые нет, будут единицы.


Найдём сумму столбца D. Это и будет количество троек, которые подходят в нашей задаче.


Кликаем по ячейке E1, нажимаем Вставить функцию и выбираем функцию СУММ. Там выбираем столбец D мышкой.


ЕГЭ по информатике 2022 - задание 9 (Формула суммы)

Нажимаем ОК, получается 2453.


Ответ: 2453

Смотреть 9 Задание на YouTube




Задание 10

С помощью текстового редактора определите, сколько раз, не считая сносок, встречается слово «долг» или «Долг» в тексте романа в стихах А.С. Пушкина «Евгений Онегин». Другие формы слова «долг», такие как «долги», «долгами» и т.д., учитывать не следует. В ответе укажите только число.





Решение:

Открываем соответствующий файл в программе Word. На вкладке "Главная" находится кнопка "Найти". Кликаем по чёрному треугольнику возле этой кнопки и выбираем "Расширенный поиск".

На вкладке "Главная" находится кнопка "Найти". Кликаем по чёрному треугольнику возле этой кнопки и выбираем "Расширенный поиск".


ЕГЭ по информатике - задание 10 (Расширенный поиск в текстовом редакторе)

Далее, нажимаем кнопку "Больше>>".


ЕГЭ по информатике - задание 10 (Расширенный поиск)

Теперь у нас есть все инструменты, чтобы решить 10 задание из ЕГЭ по информатике 2022.


В поле "Найти" пишем наше слово "долг". Галочку "Учитывать регистр" не ставим, т.к. слово может быть и с большой буквы. Но ставим галочку "Только слово целом".


Нажимаем Найти в -> "Основной документ".


ЕГЭ по информатике - задание 10 (Расширенный поиск)

Получаем ответ 1.


Ответ: 1

Смотреть 10 Задание на YouTube


Разбор демоверсии ЕГЭ по информатике 2022 (1-5 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (11-15 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (16-21 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (22-27 Задание)


30-08-2021 в 18:51:18





Поддержать сайт:


Похожая статья:

ОГЭ по информатике 2020 - Задание 2 (Простое задание!)

Привет! Сегодня разберём задание 2 из ОГЭ по информатике 2020...

Категория: Информатика  Подкатегория: ОГЭ
Дата: 11-01-2020 в 19:36:20 1



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.