вентилятор
Волк

Разбор демоверсии ЕГЭ по информатике 2022 (1-5 Задание)



Привет! Сегодня порешаем демонстрационный вариант ЕГЭ по информатике 2022.


В этой статье представлены задания с 1-ого по 5.


Источник задач: https://fipi.ru/ege/demoversii-specifikacii-kodifikatory#!/tab/151883967-5



Приятного прочтения!


Разбор демоверсии ЕГЭ по информатике 2022 (6-10 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (11-15 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (16-21 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (22-27 Задание)



Задание 1

На рисунке схема дорог Н-ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).


Задание 1 ЕГЭ по информатике демоверсия 2022

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова сумма протяжённостей дорог из пункта Б в пункт В и из пункта Г в пункт Д. В ответе запишите целое число.



Решение:

В начале нужно понять, какой город под какой буквой находится в таблице.


Точка К - особая точка, т.е. она отличается от остальных, т.к. только она имеет 6 дорог. Поэтому её легко найти в таблице, она под номером 5.


Рисунок имеет симметричную структуру. Поэтому например точки A и E мы не сможем отличить друг от друга. Но найдём примерное их расположение.





Города A и E имеют по две дороги. Значит, им соответствуют номера 1 и 3.


Городам Б и Д соответствуют номера 2 и 4. Т.к. эти номера по таблице связаны с 1 и 3. Опять, какому номеру соответствует конкретная буква, мы не сможем узнать.


С номерами 2 и 4, должны быть связаны уже В и Г. Значит, городам В и Г соответствуют номера 6 и 7.


Получается, чтобы ответить на вопрос задачи, нужно суммировать расстояния между 2 и 6 И 4 и 7.


Решение Задание 1 ЕГЭ по информатике демоверсия 2022

13+7=20

Ответ: 20

Смотреть 1 Задание на YouTube




Задание 2

Миша заполнял таблицу истинности логической функции F


¬(y → (x ≡ w)) ∧ (z → x),

но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.


Задание 2 ЕГЭ по информатике демоверсия 2022

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.


В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.


Пример. Функция F задана выражением ¬x \/ y, зависящим от двух переменных, а фрагмент таблицы имеет следующий вид.


Задание 2 ЕГЭ по информатике демоверсия 2022 пример

В этом случае первому столбцу соответствует переменная y, а второму столбцу – переменная x. В ответе следует написать: yx.





Решение:

Напишем шаблон для решения 2 задания на языке программирования Python.


print('x', 'y', 'z', 'w')
for x in range(0, 2):
    for y in range(0, 2):
        for w in range(0, 2):
            for z in range(0, 2):
                if not(not(y) or (x==w)) and (not(z) or x):
                    print(x, y, z, w)

Здесь мы перебираем все варианты с помощью вложенных циклов. И если наша функция превращается в истину, то печатаем значения переменных.


Отрицание меняется на not, следование представляем по формуле A->B = ¬A or B.


Получается


x y z w
0 1 0 1
1 1 0 0
1 1 1 0

Видно, что третий столбец - это y.


Т.к. у нас нет столбца, который состоит только из одних нулей, то в четвёртом столбце в пустой ячейке будет 1.


Решение задание 2 ЕГЭ по информатике демоверсия 2022

Получилась строчка из трёх 1. Значит, в первом столбце в пустой ячейке вверху будет 0. Следовательно, первый столбец - w.


Последний столбец достаётся z, т.к. из оставшихся переменных только у неё два 0 и одна 1. Второй столбец, по принципу исключения, - это x.


Ответ: wxyz

Смотреть 2 Задание на YouTube




Задание 3

В файле приведён фрагмент базы данных «Продукты» о поставках товаров в магазины районов города. База данных состоит из трёх таблиц.


Таблица «Движение товаров» содержит записи о поставках товаров в магазины в течение первой декады июня 2021 г., а также информацию о проданных товарах. Поле Тип операции содержит значение Поступление или Продажа, а в соответствующее поле Количество упаковок, шт. занесена информация о том, сколько упаковок товара поступило в магазин или было продано в течение дня. Заголовок таблицы имеет следующий вид.


ID
операции
Дата ID
магазина
Артикул Тип
операции
Количество
упаковок,
шт.
Цена,
руб./шт.

Таблица «Товар» содержит информацию об основных характеристиках каждого товара. Заголовок таблицы имеет следующий вид.


Артикул Отдел Наименование Ед.
изм.
Количество
в упаковке
Поставщик

Таблица «Магазин» содержит информацию о местонахождении магазинов. Заголовок таблицы имеет следующий вид.


ID
магазина
Район Адрес

На рисунке приведена схема указанной базы данных.


Задание 3 демоверсия ЕГЭ по информатике 2022

Используя информацию из приведённой базы данных, определите на сколько увеличилось количество упаковок яиц диетических, имеющихся в наличии в магазинах Заречного района, за период с 1 по 10 июня включительно.


В ответе запишите только число.


Скачать файлы




Решение (через формулу):

Откроем файл Excel. Внизу у нас три вкладки (три таблицы).


Есть магазины, есть товары, есть операции, какие товары, куда перемещаются.


Прочитаем ещё раз внимательно вопрос задачи. Переходим на вкладку Магазин. Выделим столбец "Район" и отсортируем по данному столбцу таблицу (кнопка сортировки находится обычно в правом верхнем углу). Если появится вопрос об автоматическом расширении выделенного диапазона, отвечаем утвердительно.


Теперь удобно посмотреть ID магазинов Заречного Района. Всего получается 4 ID: M3, M9, M11, M14.


Задание 3 демоверсия ЕГЭ по информатике 2022 (Excel)

Переходим на вкладку Товар. Нас интересует яйцо диетическое. Ищем по поиску (Ctrl + F) и получаем Артикул данного товара. Это номер 15.


Данные мы собрали, теперь переходим на вкладку Движение товаров.


Сначала подсчитаем сколько поступило указанного товара в указанные торговые точки за период 1-10 июня. Убедимся, что первая строчка не подходит нам по условию и в ячейке H2 ставим значение 0. Это число олицетворяет количество поступивших товаров.





В ячейке H3 пропишем формулу:


=ЕСЛИ(И(ИЛИ(C3="M3";C3="M9";C3="M11"; C3="M14"); D3=15; F3="Поступление");H2+E3;H2)

Эту формулу мы распространяем на весь столбец H. Тогда она будет анализировать каждую строчку и подсчитывать количество поступившего товара, учитывая все обстоятельства задачи. В самой последней ячейке столбца H получается число 1420. Это и есть то количество нашего товара, которое поступило в указанные торговые точки. Про дату в этой задаче думать не нужно, т.к. вся таблица по операциям происходит в пределах 1-10 июня.


Аналогично, подсчитаем в столбце I, какое количество убыло. Тогда формула получается:


=ЕСЛИ(И(ИЛИ(C3="M3";C3="M9";C3="M11"; C3="M14"); D3=15; F3="Продажа");I2+E3;I2)

Получаем количество проданных товаров 454.


Подсчитаем на сколько же увеличилось товаров:


1420-454=966

Это и будет ответ.


Ответ: 966

Смотреть 3 Задание (решение через формулу) на YouTube




Решение (через фильтры)

В подобных задачах удобно воспользоваться фильтрами!


Выбираем вкладку Магазин и нажимаем кнопку Фильтр.


Задание 3 демоверсия ЕГЭ по информатике 2022 - решение через фильтры

При этом должна быть выделена не пустая ячейка.


Кнопка Фильтр может находится и на главной панеле.


Теперь можно отфильтровать магазины Заречного района.


Задание 3 демоверсия ЕГЭ по информатике 2022 - решение через фильтры 2




Нажмём "ОК", и у нас останутся только магазины Заречного района. Фиксируем их ID.


Переходим на вкладку Товар. Включаем фильтры. С помощью фильтров оставляем только яйцо диетическое и узнаём его Артикл.


Переходим на главную вкладку Движение товаров. Включаем фильтры. Фильтруем операции, которые подходят для наших магазинов и для нашего товара.


В начале найдём количество упаковок, которые поступили в магазины, поэтому в столбце Тип операции выбираем "Поступление".


Выделяем ячейки столбца Количество упаковок для получившихся операций, и внизу смотрим сумму этих ячеек.


Задание 3 демоверсия ЕГЭ по информатике 2022 - решение через фильтры 3

Здесь нельзя пользоваться стандартной функцией СУММ, потому что она суммируем ещё и скрытые ячейки. А так мы получаем сумму выделенных ячеек.


Получается количество поступивших упаковок равно 1420. Аналогично количество убывших получается 454.


1420-454=966

Ответ: 966

Смотреть 3 Задание (решение через фильтры) на YouTube




Задание 4

Для кодирования некоторой последовательности, состоящей из букв Л, М, Н, П, Р, решили использовать неравномерный двоичный код, удовлетворяющий условию, что никакое кодовое слово не является началом другого кодового слова. Это условие обеспечивает возможность однозначной расшифровки закодированных сообщений. Для букв Л, М, Н использовали соответственно кодовые слова 00, 01, 11. Для двух оставшихся букв П и Р кодовые слова неизвестны.


Укажите кратчайшее возможное кодовое слово для буквы П, при котором код будет удовлетворять указанному условию. Если таких кодов несколько, укажите код с наименьшим числовым значением.


Решение:

Т.к. никакое кодовое слово не является началом другого кодового слова, то, значит, выполняется условие Фано.


Следовательно, можно воспользоваться приёмом дерево Фано.


Разместим буквы для которых известны коды на дереве Фано.


Задание 4 демоверсия ЕГЭ по информатике 2022 - дерево Фано

При построении дерева Фано мы проращивает от корня две ветки 0 и 1. От каждой ветки тоже можно прорастить две ветки 0 и 1 и т.д. Если буква "села" на ветку, то она блокирует эту ветку, и больше нельзя проращивать новые ответвления от неё.





У нас остались две буквы П и Р, а прорастить можем только одну ветку (из 1 - прорастить 0). Мы проращиваем эту ветку и от неё проращиваем два ответвления, и теперь мы уже можем разместить оставшиеся буквы на дереве.


Задание 4 демоверсия ЕГЭ по информатике 2022 - дерево Фано

Для П выбираем код с меньшим числовым значением - 100, как написано в условии. Букве Р достаётся код - 101.


Ответ: 100

Смотреть 4 Задание на YouTube




Задание 5

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

1. Строится двоичная запись числа N.

2. К этой записи дописываются справа ещё два разряда по следующему правилу:

а) складываются все цифры двоичной записи числа N, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001;

б) над этой записью производятся те же действия – справа дописывается остаток от деления суммы её цифр на 2.

Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью результирующего числа R.

Укажите такое наименьшее число N, для которого результат работы данного алгоритма больше числа 77. В ответе это число запишите в десятичной системе счисления.


Решение:

На вход поступает натуральное (обычное, не дробное, положительное) число N.


Это число алгоритм переводит в двоичную систему.


ЕГЭ по информатике - задание 5 Алгоритм строит новое число R

Сказано, что дописываются два разряда справа к тому двоичному числу, которое получили в первом пункте.


ЕГЭ по информатике - задание 5 дописываются два разряда справа

Про первый дополнительный разряд написано в пункте a второго правила: "складываются все цифры двоичной записи числа N, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001".


Если сказать более просто, то автомат подсчитывает количество единиц у первоначального двоичного числа N, полученного в первом пункте. Если количество чётное, то автомат в первый дополнительный разряд должен поставить 0. Если количество нечётное, то автомат в первый дополнительный разряд должен поставить 1.





Про второй дополнительный разряд сказано в пункте б второго правила. Автомат сделает тоже самое, что и в предыдущем пункте, только теперь подсчёт единиц будет происходить не только в двоичной записи числа N, но и в первом дополнительном разряде.


В вопросе просят указать входящее наименьшее число N, чтобы автомат выдал число R больше 77.


Т.к. число R должно быть больше 77, то переведём число 78 (77 + 1) в двоичный вид, чтобы можно было оценить входящее число N.


Это можно сделать стандартным калькулятором windows, переключив его в режим "Программиста" (Вид->"Программист").



Получилось число 1001110. Будем рассматривать (начиная с 1001110) числа на выполнение правил, которые заданы для алгоритма. Если все правила будут выполнены, значит, мы получили то число, по которому вычислим изначальное N. Нам нужно получить именно минимальное число, поэтому мы и начали с минимального возможного претендента для числа R (78).


Решение 5 задания демоверсии ЕГЭ по информатике 2022




Здесь нам сразу повезло, сразу число 78 удовлетворяет всем условиям. Нас просили написать именно число N, поэтому от числа 1001110 отбрасываем два разряда и переводим в десятичную систему.


Переводим в десятичную систему 10011 -> 19.


Ответ: 19

Смотреть 5 Задание на YouTube


Разбор демоверсии ЕГЭ по информатике 2022 (6-10 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (11-15 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (16-21 Задание)
Разбор демоверсии ЕГЭ по информатике 2022 (22-27 Задание)


27-08-2021 в 07:56:24







Поддержать сайт:

Похожая статья:

ЕГЭ по информатике 2021 - Задание 14 (Чемпионская подготовка)

Мы подошли к 14 заданию из ЕГЭ по информатике 2021. Оно связано с разл...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 05-10-2020 в 13:07:44 0


Комментарии:

Очень доступное объяснение. Жду разбор следующих заданий
Ольга 13-09-2021 в 20:39:33

Следующие задания уже разобраны из Демоверсии 2022. Можете посмотреть в разделе ЕГЭ.
Калужский Александр 13-09-2021 в 20:42:20

спасибо,но где дальше
ольга диколенко 05-01-2022 в 12:48:03

Ссылки на продолжение есть в начале статьи и в конце статьи)
Калужский Александр 05-01-2022 в 12:50:00

ох лучше готовится зарание чем за мес до экзамена
Иван Иванов 25-04-2022 в 23:41:51



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.