вентилятор
Волк

ОГЭ по информатике. Вторая часть. Определение количество элементов - задачи на Паскаль (Pascal)



Определение КОЛИЧЕСТВО элементов, КРАТНЫХ 8.

Задача 1

Напишите программу, которая в последовательности натуральных чисел определяет КОЛИЧЕСТВО элементов, КРАТНЫХ 8. В последовательности всегда имеется число, кратное 8. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – КОЛИЧЕСТВО элементов, КРАТНЫХ 8.


Решение:

Вначале Количество равно нулю. Перебираем в ЦИКЛЕ числа. Если нам попался элемент, кратный 8 (остаток от деления на 8 равен нулю), то мы плюсуем 1 к нашему количеству.


var a, i, quantity, n: integer;
begin
  read(n);
  quantity:=0;
  for i:=1 to n do
  begin
    read(a);
    if a mod 8 = 0 then
      quantity:= quantity + 1;
  end;
  writeln(quantity);
end.

Определение КОЛИЧЕСТВО элементов, оканчивающихся на 8.

Задача 2

Напишите программу, которая в последовательности натуральных чисел определяет КОЛИЧЕСТВО элементов, оканчивающихся на 8. В последовательности всегда имеется число, оканчивающееся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – КОЛИЧЕСТВО элементов, оканчивающихся на 8.


Решение:

Вначале Количество равно нулю. Перебираем в ЦИКЛЕ числа. Если нам попался элемент, оканчивающийся на 8 (остаток от деления на 10 равен 8), то мы плюсуем 1 к нашему количеству.


var a, I, quantity, n: integer;
begin
  read(n);
  quantity:=0;
  for i:=1 to n do
  begin
    read(a);
    if a mod 10 = 8 then
      quantity:= quantity + 1;
  end;
  writeln(quantity);
end.

Определение КОЛИЧЕСТВО элементов, БОЛЬШИХ 10.

Задача 3

Напишите программу, которая в последовательности натуральных чисел определяет КОЛИЧЕСТВО элементов, больших 10. В последовательности всегда имеется число, который больше 10. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – КОЛИЧЕСТВО элементов, оканчивающихся на 8.


Решение:

Вначале Количество равно нулю. Перебираем в ЦИКЛЕ числа. Если нам попался элемент, который больше 10, то мы плюсуем 1 к нашему количеству.


var a, i, quantity, n: integer;
begin
  read(n);
  quantity:=0;
  for i:=1 to n do
  begin
    read(a);
    if a > 10 then
      quantity:= quantity + 1;
  end;
  Writeln(quantity);
end.

Определение КОЛИЧЕСТВО элементов, БОЛЬШИХ 15 и КРАТНЫХ 7.

Задача 4

Напишите программу, которая в последовательности натуральных чисел определяет КОЛИЧЕСТВО элементов, БОЛЬШИХ 15 и КРАТНЫХ 7. В последовательности всегда имеется число, которое БОЛЬШОЕ 15 и КРАТНОЕ 7 Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – КОЛИЧЕСТВО элементов, БОЛЬШИХ 15 и КРАТНЫХ 7.


Решение:

Вначале Количество равно нулю. Перебираем в ЦИКЛЕ числа. Если нам попался элемент, который больше 15 И кратное 7 (остаток от деления на 7 равен 0), то мы плюсуем 1 к нашему количеству.


var a, i , quantity, n: integer;
begin
  read(n);
  quantity:=0;
  for i:=1 to n do
  begin
  read(a);
  if (a > 15) and (a mod 7 = 0) then
    quantity:= quantity + 1;
  end;
  writeln(quantity);
end.


28-09-2018 в 14:05:11







Поддержать сайт:

Похожая статья:

ЕГЭ по информатике - Задание 17 (Круги Эйлера)

Сегодня разберём задачу на круги Эйлера в информатике....

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 27-07-2020 в 08:49:41 1



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.