Всемирный день риса

Досрочный ЕГЭ по информатике 2023 (Задания 1-10)



Сегодня разберём, что было на досрочном ЕГЭ по информатике, который прошёл 06.04.23.


Реальный экзамен, как правило, очень похож на досрочный экзамен по информатике. Поэтому очень важно прорешать и проанализировать данные задачи.


Ещё лучше подготовится к ЕГЭ по информатике, Вы можете по материалам сайта Code-Enjoy.





Файлы, ответы и формулировки могут не совпадать с реальным досрочным экзаменом, а данная статья лишь примерно показывает прототипы задач.


Досрочный ЕГЭ по информатике 2023 (Задания 11-21)
Досрочный ЕГЭ по информатике 2023 (Задания 22-27)

Задание 1

На рисунке справа схема дорог Н-ского района изображена в виде графа, в таблице содержатся сведения о длинах этих дорог (в километрах).


Досрочный ЕГЭ по информатике 2023 - Задание 1

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова длина дороги из пункта Г в пункт К.


Решение:

Особой точкой является город Г. Только к этому городу ведут ровно три дороги. Это точка будет пункт П2.


Теперь нужно найти соседа пункта П2, к которому ведут ровно две дороги. Это и будет точка К.


Соседи пункта П2: П1 (к нему ведут две дороги), П4 (4 дороги), П6 (5 дорог). Мы выбираем П1 — это точка К.


Длина дороги из пункта Г в пункт К будет равна 45. Это число находится на пересечении П1 и П2 в таблице.


Ответ: 45



Задание 2

Логическая функция F задаётся выражением

(x ∨ ¬y) ∧ ¬(y ≡ z) ∧ ¬w

На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F ложна. Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z.


Досрочный ЕГЭ по информатике 2023 - Задание 2 (Таблица)

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала – буква, соответствующая первому столбцу; затем – буква, соответствующая второму столбцу, и т.д.) Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.


Решение:

Решать будем с помощью шаблона на Python.


print('x y z w')
for x in range(0, 2):
    for y in range(0, 2):
        for z in range(0, 2):
            for w in range(0, 2):
                if (x or not(y)) and not((y == z)) and not(w):
                    print(x, y, z, w)

Получим следующий результат:


Досрочный ЕГЭ по информатике 2023 - Задание 2 (Решение)

Переменная w может быть только в последнем столбце, т.к. в остальных столбцах есть хотя бы одна единица.


Переменная y может быть только в третьем столбце, т.к. в остальных столбцах минимум 2 единицы, а у переменой y в столбце только одна единица.


В строке, где у переменной y единица, так же единица и у переменной x. Поэтому переменной x достаётся первый столбец.


По остаточному принципу переменной z достаётся второй столбец.


Ответ: xzyw



Задание 3

В файле приведён фрагмент базы данных «Кондитерские изделия» о поставках конфет и печенья в магазины районов города. База данных состоит из трёх таблиц.


Таблица «Движение товаров» содержит записи о поставках товаров в магазины в течение первой половины августа 2021 г., а также информацию о проданных товарах. Поле Тип операции содержит значение Поступление или Продажа, а в соответствующее поле Количество упаковок, шт внесена информация о том, сколько упаковок товара поступило в магазин или было продано в течение дня. Заголовок таблицы имеет следующий вид.


ID
операции
Дата ID
магазина
Артикул Количество
упаковок,
шт.
Тип операции

Таблица «Товар» содержит информацию об основных характеристиках каждого товара. Заголовок таблицы имеет следующий вид.


Артикул Отдел Наименование товара Ед_изм Количество
в упаковке
Цена за упаковку

Таблица «Магазин» содержит информацию о местонахождении магазинов. Заголовок таблицы имеет следующий вид.


ID
магазина
Район Адрес

На рисунке приведена схема указанной базы данных.


Досрочный ЕГЭ по информатике 2023 - Задание 3 (Таблица)

Используя информацию из приведённой базы данных, определите, на сколько увеличилось количество упаковок пряников тульский с начинкой имеющихся в наличии в магазинах Заречного района, за период со 2 по 15 августа включительно.


В ответе запишите только число.


Скачать файл


Решение:

Найдём артикул товара "пряник тульский с начинкой".


Открываем вкладку "Товар", кликаем в ячейку F1, выбираем кнопку на вкалдке "Главная" -> Сортировка и фильтр -> Фильтр.


Задание 3 досрочный ЕГЭ по информатике 2023 - решение через фильтры

Кнопка Фильтр может находится и на главной панели. Теперь можно отфильтровать товар только "пряник тульский с начинкой".


Досрочный ЕГЭ по информатике 2023 - Задание 3 (Решение)




Получается номер артикула: 57.


Аналогично отфильтровываем магазины Заречного района. Получаются номера ID: M3, M9, M11, M14, M17.


После этого, переходим на вкладку "Движение товаров". Так же включаем фильтры и оставляем только нужный артикул пряника тульского с начинкой и нужные ID магазинов.


Если мы ещё отфильтруем товар по типу "поступления", мы узнаем сколько упаковок пряников тульских с начинкой пришло в нужные нам магазины. После фильтрации остаётся только нужные даты, поэтому про даты беспокоится не нужно.


Досрочный ЕГЭ по информатике 2023 - Задание 3 (Решение) 2

Выделяем ячейки столбца Количество упаковок и внизу смотрим сумму этих ячеек. Получается 2000 упаковок.


Здесь нельзя пользоваться стандартной функцией СУММ, потому что она суммируем ещё и скрытые ячейки. А так мы получаем сумму выделенных ячеек.


Аналогично находим, сколько товаров было продано. В столбце "Тип операции" отфильтровываем по типу "Продажа".


Получается, продали 1545 упаковок. Все даты вновь подходят.


Следовательно, увеличилось на 2000 - 1545 = 455 упаковок пряников тульских с начинкой в указанных магазинах за период со 2 по 15 августа включительно.


Ответ: 455



Задание 4

Для кодирования некоторой последовательности, состоящей из букв 10 букв решили использовать неравномерный двоичный код, удовлетворяющий условию, что никакое кодовое слово не является началом другого кодового слова. Это условие обеспечивает возможность однозначной расшифровки закодированных сообщений. Известны кодовые слова для букв:


Досрочный ЕГЭ по информатике 2023 - Задание 4

Укажите кратчайшее кодовое слово для буквы Е, при котором код будет удовлетворять условию Фано. Если таких кодов несколько, укажите код с наименьшим числовым значением.


Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.


Решение:

Расположим уже известные буквы на дереве Фано.


Досрочный ЕГЭ по информатике 2023 - Задание 4 (решение)

У нас единственное место на дереве осталось — 1011.


Досрочный ЕГЭ по информатике 2023 - Задание 4 (решение) 2

Ответ: 1011



Задание 5

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.


1. Строится двоичная запись числа N.


2. Далее эта запись обрабатывается по следующему правилу:


а) если N делится на 3, то в конец этой записи дописывается три последние цифры двоичной записи.


б) если N не делится на 3, то остаток при делении на 3 числа N умножается на 3, переводится в двоичную запись и дописывается в конец двоичной записи числа N.


Полученная таким образом запись является двоичной записью искомого числа R.


Например, для исходного числа 1210 = 11002 результатом является число 11001002 = 10010, а для исходного числа 410 = 1002 результатом является число 100112 = 1910.


Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, не меньшее 100. В ответе запишите это число в десятичной системе счисления.


Решение:

Решим задачу на языке Python.


for n in range(4, 1000):
    s=format(n, 'b')

    if n%3==0:
        s = s + s[-3] + s[-2] + s[-1]
    else:
        s = s + format((n%3)*3, 'b')

    r=int(s, 2)

    if r>=100:
        print(n)

Перебираем числа для переменной n от 4 до 999.


Пробуем подставить каждое значение вместо n.


С помощью функции format() переводим в двоичную систему. Получаем результат в виде строки.


Чтобы обратится к последнему символу строки, можно использовать конструкцию s[-1]. Чтобы обратится к предпоследнему — s[-2], к предпредпоследнему — s[-3].


Мы начинаем перебирать переменную n c 4, т.к. например, тройка в двоичной системе имеет только две цифры (11), и мы никак не сможем обратится к третьей цифре с конца.


С помощью функции int() переводим из строки в двоичной системе обратно в число в десятичной системе.


Наименьшее число, которое выведет программа равно 12.


Ответ: 12



Задание 6

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует 4 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n – целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.


Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.


Черепахе был дан для исполнения следующий алгоритм:


Направо 45 Повтори 7 [Вперёд 5 Направо 45 Вперёд 10 Направо 135]


Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.


Решение:

Решим задачу в программе Кумир от НИИСИ РАН. Как решать данное задание в программе Кумир, мы говорили в этой статье.


использовать Черепаха
алг
нач
  опустить хвост
  вправо(45)
  нц 7 раз
    вперед(5)  
    вправо(45)
    вперед(10)
    вправо(135)
  кц
кон




Необходимо настроить масштабирование на 1.


Досрочный ЕГЭ по информатике 2023 - Задание 6 (Рисунок в программе Кумир масштабирование)

Досрочный ЕГЭ по информатике 2023 - Задание 6 (Подсчитываем точки)

Получается 27 точек.


Ответ: 27



Задание 7

Голосовое сообщение длительностью 90 секунд, записанное в формате стерео с частотой дискретизации 48 000 измерений в секунду, битовой глубиной 16 бит, передаётся через канал связи с пропускной способностью 3200 бит/c. За сколько секунд передастся данное сообщение?


Решение:

Найдём информационный объём голосового сообщения по формуле.


ЕГЭ по информатике - задание 7 (Формула дискретизации)

Досрочный ЕГЭ по информатике 2023 - задание 7 (Решение)

Найдём, за сколько передастся файл при скорости передачи 3200 бит/c.


Досрочный ЕГЭ по информатике 2023 - задание 7 (Решение) 2

Ответ: 43200



Задание 8

Все четырёхбуквенные слова, в составе которых могут быть только буквы А, Б, З, И записаны в алфавитном порядке и пронумерованы начиная с 1. Ниже приведено начало списка.


1. АААА
2. АААБ
3. АААЗ
4. АААИ
5. ААБА
6. ААББ
7. ………

Под каким номером в списке идёт слово ИЗБА?


Решение:

Решим задачу на языке Python. Совсем недавно добавил в статью по 8 заданию примеры, как решать задачи со списками с помощью программирования.


k=0

for x1 in 'АБЗИ':
    for x2 in 'АБЗИ':
        for x3 in 'АБЗИ':
            for x4 in 'АБЗИ':
                s=x1+x2+x3+x4
                k=k+1

                if s=='ИЗБА':
                    print(k)  

Ответ получается 229.


Ответ: 229



Задание 9

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:


— в строке все числа различны;

— удвоенная сумма максимального и минимального числа не меньше суммы трёх других чисел.


В ответе запишите только число.


Скачать файл

Решение:

Расставим единицы напротив тех строчек, которые подходят под первое условие.


В ячейку F1 пропишем формулу:


=ЕСЛИ(И(A1<>B1; A1<>C1; A1<>D1; A1<>E1; B1<>C1; B1<>D1; B1<>E1; C1<>D1; C1<>E1; D1<>E1); 1; 0)

Здесь просто перебрали все варианты между парами. Распространим эту формулу на весь столбец.


Досрочный ЕГЭ по информатике 2023 - задание 9 (Решение)

Так же расставим единицы напротив тех строчек, которые подходят по второму условию.


В ячейке G1 напишем формулу для удвоенной суммы минимального и максимального числа:


=(МИН(A1:E1) + МАКС(A1:E1))*2

Распространим формулу на весь столбец.


В ячейке H1 напишем формулу для суммы трёх оставшихся чисел:


=СУММ(A1:E1)-МИН(A1:E1)-МАКС(A1:E1)

Здесь мы из суммы всех пяти чисел отнимаем максимальное и минимальное число.


Распространим формулу на весь столбец.


В ячейке I1 расставим единицы для строчек, которые подходят по второму условию:


=ЕСЛИ(G1>=H1;1;0)




В ячейке J1 расставим единицы для тех строчек, которые удовлетворяют двум условиям одновременно:


=ЕСЛИ(F1+I1=2;1;0)

Распространим формулу на весь столбец.


Чтобы ответить на вопрос задачи, достаточно найти сумму столбца J. Выделим столбец J и посмотрим сумму в правом нижним углу.


Досрочный ЕГЭ по информатике 2023 - задание 9 (Решение) 2

Ответ получается 2410.


Ответ: 2410



Задание 10

Текст произведения Куприна «Поединок» представлен в виде файла различных форматов. Откройте его и определите, сколько раз, не считая сносок, встречаются в тексте сочетание букв «удар» или «Удар», например «ударник», «ударил». Отдельные слова «Удар» и «удар» учитывать не следует.


Скачать файл

Решение:

Найдём, сколько раз встречаются сочетания букв "удар" или "Удар" в тексте.


На вкладке "Главная" находится кнопка "Найти". Кликаем по чёрному треугольнику возле этой кнопки и выбираем "Расширенный поиск".


ЕГЭ по информатике - задание 10 (Расширенный поиск в текстовом редакторе)

Далее, нажимаем кнопку "Больше>>".


ЕГЭ по информатике - задание 10 (Расширенный поиск)

Теперь у нас есть все инструменты, чтобы решить 10 задание из ЕГЭ по информатике.


В поле "Найти" пишем наше слово "удар".


Нажимаем Область поиска -> "Основной документ".


ЕГЭ по информатике - задание 10 (Расширенный поиск)

Получается 56 совпадений.


Теперь найдём, сколько отдельных слов "удар" или "Удар" в тексте. Поставим галочку Только слово целиком.


Нажимаем область поиска -> "Основной документ".


Получается 6 отдельных слов.


Чтобы ответить на вопрос задачи нужно из 56 вычесть 6.


56 - 6 = 50

Ответ: 50
Досрочный ЕГЭ по информатике 2023 (Задания 11-21)
Досрочный ЕГЭ по информатике 2023 (Задания 22-27)



10-04-2023 в 15:00:18





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2021 - Задание 9 (Таблица Excel)

Девятое задание из ЕГЭ по информатике нового формата 2021 основывается...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 14-09-2020 в 19:13:54 6


Комментарии:

Мужик, мужики, подскажите в 10 задании как формулой можно решить?
Мужик 15-05-2023 в 16:06:02



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.