вентилятор
Хорошего настроения!

ЕГЭ по информатике 2022 - Задание 14 (Чемпионская подготовка)



Мы подошли к 14 заданию из ЕГЭ по информатике 2022. Оно связано с различными системами счисления. Что такое различные системы счисления, мы рассматривали в этой статье. Так же будет полезно посмотреть эту статью.


Переходим к первому тренировочному 14-ому заданию из ЕГЭ по информатике. Раньше это задание было под номером 16.





Задача (ЕГЭ по информатике, 2019, Москва)

Значение выражения 536 + 524 - 25 записали в системе счисления с основанием 5. Сколько цифр "4" содержится в этой записи?


Решение:

Первый способ. (С помощью Питона)

f = 5**36 + 5**24 - 25

k=0

while f>0:
    if f%5==4:
        k=k+1
    f = f // 5

print(k)




В переменную f записываем функцию. Две звёздочки подряд обозначают возведение в степень. Заводим строчку k, которая будет отвечать за ответ.


Сам перевод числа f в пятеричную систему происходит в цикле WHILE.


Вычисляем остатки от деления на 5. Очередная цифра в 5-ричной системе, это и есть остаток при делении f на 5. Если очередной остаток равен нужной цифре "4", то мы прибавляем счётчик k. Так же производим целочисленное деление на 5, чтобы остатки менялись. Алгоритм точно такой же, как если бы переводили на листке бумаги делением уголком.


Продолжая данный алгоритм, в переменной f будет рано или поздно 0.


Важно понимать, что в начале у нас идёт последняя цифра в пятиричной системе, при следующем проходе цикла - предпоследняя и т.д.


В ответе напишем 22.


Второй способ. (Классический)

Сформулируем главное правило, на которое будем опираться при решении подобного типа задач.


ЕГЭ по информатике 2022 - задание 14 (основное правило)




Примеры:
54 (в десятичной системе) - это 100005 (в пятеричной системе)
72 (в десятичной системе) - это 1007 (в семеричной системе)
29 (в десятичной системе) - это 10000000002 (в двоичной системе)

Перепишем наше выражение, чтобы все числа были в виде степени представлены.


536 + 524 - 52

Посчитаем 536 + 524 в пятеричной системе столбиком, используя основное правило.


ЕГЭ по информатике 2022 - задание 14 (суммируем столбиком в пятеричной системе)

Здесь всё просто: ноль прибавить ноль, будет ноль. Единица плюс ноль, будет один.


Теперь от получившегося числа нужно отнять 52 (1005).


ЕГЭ по информатике 2022 - задание 14 (вычитаем столбиком в пятеричной системе)




Первые два разряда посчитать легко. Ноль минус ноль, будет ноль.


Третий разряд: из нуля отнять единицу мы не можем, поэтому занимаем у более старших разрядов.


В более старших разрядах тоже нули, поэтому идём до единицы, у которой можно занять. Получается 22 четвёрки.


Вот как было бы, если бы считали в нашей родной десятичной системе счисления в аналогичной ситуации.


Здесь мы считаем в десятичной системе, поэтому получаются девятки. В нашей задаче считали в пятеричной системе, поэтому получаются четвёрки.


ЕГЭ по информатике 2022 - задание 14 (вычитаем столбиком в десятичной системе)

В ответе напишем 22 четвёрки.


Ответ: 22



Задача (ЕГЭ по информатике, 2020, Москва)

Значение выражения 168 × 420 - 45 - 64 записали в системе счисления с основанием 4. Сколько цифр "3" содержится в этой записи?


Решение:

Первый способ. (С помощью Питона)

f = 16**8 * 4**20 - 4**5 - 64

k=0

while f>0:
    if f%4==3:
        k=k+1
    f = f // 4

print(k)


Второй способ. (Классический)

Преобразуем наше выражение. Приведём всё к 4-ам.


168 × 420 - 45 - 64 =
= (42)8 × 420 - 45 - 43 =
= 416 × 420 - 45 - 43 =
= 436 - 45 - 43

Здесь не можем применить технику устного счёта, потому что стоят два минуса. Значит, будем решать с помощью столбиков.





Сначала посчитаем 436 - 45.


ЕГЭ по информатике 2022 - задание 14 (решение 2020 Москва)

Теперь от этого числа нужно отнять 43 (10004)


ЕГЭ по информатике 2022 - задание 14 (решение 2020 Москва 2)




Получается 32 тройки.


В последнем вычислении нет ничего сложно. В десятичной системе вы бы легко вычислили в аналогичной ситуации.


ЕГЭ по информатике 2022 - задание 14 (решение 2020 Москва 2 десятичная система)


Ответ: 32



Задача (Тренировочная)

Укажите через запятую в порядке возрастания все десятичные натуральные числа, не превосходящие 17, запись которых в троичной системе счисления оканчивается на две одинаковые цифры.


Решение:

1) Переведём число 17 в троичную систему.


ЕГЭ по информатике 2022 - задание 14 (переводим в троичную систему)

Получилось 1223.





2) Теперь выпишем все числа, которые не превосходят 1223 (Т.е. 1223 тоже подходит!), запись которых в троичной системе счисления оканчивается на две одинаковые цифры. В троичной системе могут применяться цифры 0, 1, 2.


1223
1223
1113
1003
223
113

Теперь переведём эти числа в десятичную систему.


1223 = 2 × 30 + 2 × 31 + 1 × 32 = 1710
1113 = 1 × 30 + 1 × 31 + 1 × 32 = 1310
1003 = 0 × 30 + 0 × 31 + 1 × 32 = 910
223 = 2 × 30 + 2 × 31 = 810
113 = 1 × 30 + 1 × 31 = 410

Ответ: 4, 8, 9, 13, 17

Ещё один интересный тип задания номер 14, который вполне может быть на реальном ЕГЭ по информатике 2022.





Задача (Уравнение)

Чему равно наименьшее основание позиционной системы счисления x, при котором 225x = 405y? Ответ записать в виде целого числа.


Решение:

Переведём каждое из чисел 225x и 405y в десятичную систему счисления и приравняем, т.к. эти числа равны.


5 × x0 + 2 × x1 + 2 × x2 = 5 × y0 + 0 × y1 + 4 × y2

Любое число в нулевой степени - это 1. Значит, 5 × x0 = 5 × y0 = 5. Эти два выражения равны одному и тому же значению, следовательно, их можно убрать и слева, и справа.


2x + 2x2 = 4y2
x + x2 = 2y2
x(1 + x) = 2y2

Получили уравнение в целых числах. Слева умножение двух последовательных чисел. Нужно начать подбирать целые числа.






При y = 6 :

x (1 + x) = 2 × 62 = 72 ; Произведение двух последовательных чисел 8 * 9 = 72. Значит, x = 8.



Мы начали проверку с числа 6, потому что у нас в уравнении присутствуют цифра 5. Значит, система счисления может быть минимум с основанием 6.


Получается, что наименьшее значение x равно 8.


В подобных задач нужно знать, что числа обязательно найдутся, нужно их просто хорошо поискать.


Ответ: 8

Для качественной проработки 14 задания из ЕГЭ по информатике 2022 разберём ещё некоторые задачи.





Задача (Основание системы)

Запись числа 338 в системе счисления с основанием N содержит 3 цифры и оканчивается на 2. Чему равно максимально возможное основание системы счисления?


Решение:

В этой задаче применим формулу:


ЕГЭ по информатике 2022 - задание 14 (Формула)

Примером для данной формулы можно взять два разряда в двоичной системе. Максимальное число в двоичной системе равно 112. А в десятичной системе это число равно 310. Т.е. 22 - 1.


338 число будет точно больше, чем двухзначное число с основанием N.


Получается неравенство:


338 > N2 - 1
N2 < 339




N - положительное целое число. Тогда:


N < √339 ≈ 18
N ≤ 18

Сказано, что число в системе с основанием N оканчивается на 2. Поэтому первый остаток должен быть равен 2!


ЕГЭ по информатике 2021 - задание 14 (Число оканчивается на 2)

Будем идти вниз от числа 18 и проверять, на что делится 336.


Число 336 должно делится на N.


Подошло число 16 (16 * 21 = 336!)


Ответ: 16



Продолжаем подготовку к 14 заданию из ЕГЭ по информатике 2022


Задача (На понимание)

Запись числа в девятеричной системе счисления заканчивается цифрой 4. Какой будет последняя цифра в записи этого числа в троичной системе счисления?


Решение:

Подберём такие числа в десятичной системе, которые в остатке при первом делении на 9 дадут 4!


Посмотрим, какой остаток будет при делении этого же числа на 3 при первом делении. Получается 1. Это и будет ответ.


ЕГЭ по информатике 2022 - задание 14 (Последняя цифра в троичной системе)
Ответ: 1



Задача (Закрепление материала)

Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 23 оканчивается на 2.


Решение:

Нужно перебрать все числа от 3 до 23 и определить, какие из них при делении числа 23 дадут остаток 2.


23 : 3 = 7 (ост. 2) +
23 : 4 = 5 (ост. 3) -
23 : 5 = 4 (ост. 3) -
23 : 6 = 3 (ост. 5) -
23 : 7 = 3 (ост. 2) +
23 : 8 = 2 (ост. 7) -
23 : 9 = 2 (ост. 5) -
23 : 10 = 2 (ост. 3) -
23 : 11 = 2 (ост. 1) -
23 : 12 = 1 (ост. 11) -
23 : 13 = 1 (ост. 10) -
23 : 14 = 1 (ост. 9) -
23 : 15 = 1 (ост. 8) -
23 : 16 = 1 (ост. 7) -
23 : 17 = 1 (ост. 6) -
23 : 18 = 1 (ост. 5) -
23 : 19 = 1 (ост. 4) -
23 : 20 = 1 (ост. 3) -
23 : 21 = 1 (ост. 2) +
23 : 22 = 1 (ост. 1) -
23 : 23 = 1 (ост. 0) -

Подходят числа 3, 7, 21.


Здесь можно и написать программу:


for i in range(3, 24):
    if 23%i==2:
        print(i)

Ответ: 3, 7, 21



Задача (Добьём 14 задание из ЕГЭ по информатике 2022)

В некоторой системе счисления записи десятичных чисел 66 и 40 заканчиваются на 1. Определите основание системы счисления.


Решение:

Нужно найти такое число, чтобы числа 66 и 40 при делении на это число давали остаток 1.


Т.е. искомое число должно быть делителем чисел 65 (66-1) и 39 (40-1). У числа 39 не так много делителей: 1, 3, 13, 39


Видим, что число 65 делится на 13 (65 : 13 = 5). Поэтому искомое число равно 13.


Ответ: 13



Задача (Для чемпионов!)

В какой системе счисления выполняется равенство 12 · 13 = 222?
В ответе укажите число – основание системы счисления.


Решение:

Если бы мы находились в десятичной системе, то последней цифрой была бы 6 (2 * 3). Но у нас 2! Т.е. Система счисления меньше или равна 6, т.к. если бы система счисления была больше 6, то у нас была бы 6 последняя цифра.


Шестёрка не "поместилась" в младший разряд, от неё осталось только 2. Остальные 4 единицы ушли в более старший разряд. Если 4 единицы составляют единицу более старшего разряда, то значит, мы находимся в четверичной системе.


Ответ: 4



Задача (Новый тип, Статград окт 2022)

В выражении 1xBAD16 + 2CxFE16 x обозначает некоторую цифру из алфавита шестнадцатеричной системы счисления. Определите наименьшее значение x, при котором значение данного выражения кратно 15. Для найденного x вычислите частное от деления данного выражения на 15 и запишите его в ответе в десятичной системе счисления.


Решение:

Здесь дана сумма чисел, которые написаны в шестнадцатеричной системе счисления.


Мы будем перебирать каждую цифру из шестнадцатеричной системы (0-15) с помощью цикла. Нас будут интересовать те значения x, при котором сумма этих чисел будет делится на 15.


for x in range(0, 16):
    a=13*16**0 + 10*16**1 + 11*16**2 + x*16**3 + 1*16**4
    b=14*16**0 + 15*16**1 + x*16**2 + 12*16**3 + 2*16**4
    if (a+b)%15==0:
        print(x, (a+b)//15)

Чтобы проверить, делится ли данное выражение на 15, переводим оба слагаемых в нашу родную десятичную систему. Переводим стандартным образом, об этом можно прочитать здесь.


В задаче нужно написать для наименьшего найденного значения x результат от деления данной суммы на 15.


Получается 18341


Ответ: 18341



Задача(Новый тип, закрепление)

(Богданов) Операнды арифметического выражения записаны в системе счисления с основанием 17:


9759x17 + 3x10817

В записи чисел переменной x обозначена неизвестная цифра из алфавита 17-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратного 11. Для найденного значения x вычислите частное от деления значения арифметического выражения на 11 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.


Решение:

Решим задание с помощью предыдущего шаблона на языке Python.


for x in range(0, 17):
    a=x*17**0 + 9*17**1 + 5*17**2 + 7*17**3 + 9*17**4
    b=8*17**0 + 0*17**1 + 1*17**2 + x*17**3 + 3*17**4
    if (a+b)%11==0:
        print(x, (a+b)//11)

Ответ: 95306



Задача (Новый тип, две переменные)

Числа M и N записаны в системах счисления с основаниями 15 и 13 соответственно.

M = 2y23x515, N = 67x9y13

В записи чисел переменными x и y обозначены допустимые в данных системах счисления неизвестные цифры. Определите наименьшее значение натурального числа A, при котором существуют такие x, y, что M + A кратно N.


Решение:

Принцип решения данной задачи похож на решение 15 задания из ЕГЭ по информатике.



for A in range(1, 5000):
    for x in range(0, 13):
        for y in range(0, 13):   
            M=5*15**0 + x*15**1 + 3*15**2 + 2*15**3 + y*15**4 + 2*15**5
            N=y*13**0 + 9*13**1 + x*13**2 + 7*13**3 + 6*13**4
            if (M+A)%N==0:
                print(A)

Нужно найти A, значит, начинаем перебирать A. Идём от 1, т.к. речь идёт о натуральных числах. Перебираем x и y. Они могут принимать значения из алфавита в 13-ой системе. Берём меньшую, т.к. эти переменные и в первом числе, и во втором одинаковые.


Если выполняется условие задачи, то нам интересно такое A при котором это произошло.


В этой задаче A получается достаточно большим, поэтому перебираем эту переменную до 5000.


Ответ: 1535



На этом всё! Вы прошли чемпионскую тренировку по подготовке 14 задания из ЕГЭ по информатике 2022. Успехов на экзамене!








02-12-2021 в 12:12:09





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2021 - Задание 22 (Анализируем программу)

Здравствуйте! Будем тренироваться решать 22 задание из ЕГЭ по информат...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 17-12-2020 в 13:48:04 4


Комментарии:

"В переменную f записываем функцию". В переменную f мы записываем не функцию, а выражение
Ягуар 19-04-2022 в 08:16:49

Господа, вот это я понимаю, по-настоящему чемпионская подготовка. Тут же и язык свой придумали, и решение на нём сделали. Скажите, зачем над змеёй то издеваться? Очень уж режет слух неправильное произношение. "Пайтон" - вот как должно быть. Я бы промолчал, увидев это раз, но видя подобное насилие над словом постоянно - молчать более не могу
Никита 13-06-2022 в 13:04:25

Никита, Haters gonna hate
2UN 30-07-2022 в 17:43:09

Для ласт задачи модно сделать код куда проще и короче for a in range(1, 10000): for x in '0123456789ABC': for y in '0123456789ABC': M = int(f'2{y}23{x}5', 15) N = int(f'67{x}9{y}', 13) if (M + a) % N == 0: print(a) break
Fhn 16-01-2023 в 14:44:12

Первое задание, первое решение, очепятка: "В ответе напишем 4", вместо: "В ответе напишем 22". И спасибо Вам за этот сайт!)
un 19-01-2023 в 15:21:07

Исправил, Спасибо!
Калужский Александр 19-01-2023 в 15:54:11

for x in range (0,17): a = (9*17**4)+(7*17**3)+(5*17**2)+(9*17**1)+x b = (3*17**4)+(x*17**3)+(1*17*22)+(0*17**1)+8 if (a+b)%11==0: print ((a+b)//11) break почему не работает?
what fack 05-06-2023 в 06:29:44

Сделайте, как у меня, и заработает
Калужский Александр 05-06-2023 в 10:57:38



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.