Всемирный день риса

ОГЭ по информатике. Задачи на паскаль. Нахождение МАКСИМАЛЬНОГО И МИНИМАЛЬНОГО элемента.



Задача 1

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число.





Решение:

Считаем сначала максимальным числом самое маленькое из возможных, т.е. ноль. Потом, перебираем все числа – если встретилось число большее, чем максимальное в данный момент, то оно и становится максимальным.


Var a, i, max, n: integer;
begin
  Read(n);
  max:=0;
  for i:=1 to n do
  begin
    read(a);
    if a>max then max:=a;
  end;
Writeln(max);
end.




Нахождение МИНИМАЛЬНОГО числа.

Задача 2

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число.



Решение:

Считаем сначала минимальным числом самое большое из возможных, т.е. 30000. Потом, перебираем все числа – если встретилось число меньшее, чем минимальное в данный момент, то оно и становится минимальным.


Var a, i, min, n: integer;
begin
  Read(n);
  min:=30000;
  for i:=1 to n do
  begin
    read(a);
    if a>min then min:=a;
  end;
Writeln(min);
end.




Нахождение МАКСИМАЛЬНОГО числа КРАТНОГО 7.

Задача 3

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 7. В последовательности всегда имеется число, кратное 7. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – максимальное число, кратное 7.



Решение:

Считаем сначала максимальным числом самое маленькое из возможных, т.е. ноль. Потом, перебираем все числа – если встретилось число кратное 7 (остаток от деления на 7 равен нулю), И большее, чем максимальное в данный момент, то оно и становится максимальным.


Var a, i, max, n: integer;
begin
  Read(n);
  max:=0;
  for i:=1 to n do
  begin
    read(a);
    if (a>max) and (a mod 7 = 0) then max:=a;
  end;
Writeln(max);
end.




Нахождение МАКСИМАЛЬНОГО числа, ОКАНЧИВАЮЩЕЕСЯ на 6.

Задача 4

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 6. В последовательности всегда имеется число, оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – максимальное число, оканчивающееся на 6.


Решение:

В начале, максимальное число считается самым маленьким из всех возможных. Т.е. нулю. Затем перебираем числа в массиве. Если нам встретилось число, ОКАНЧИВАЮЩЕЕСЯ на 6 (Т.е. остаток от деления на 10 равен 6), И это число больше, чем наше максимальное в данный момент, то у нас становится новое максимальное – это число.


Var a, i, max, n: integer;
begin
  Read(n);
  max:=0;
  for i:=1 to n do
  begin
    read(a);
    if (a>max) and (a mod 10 = 6) then max:=a;
  end;
Writeln(max);
end.


13-09-2018 в 08:13:19





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2022 - Задание 5 (Линейный алгоритм)

Привет! В этой статье будут различные примеры решения задач из 5-ого з...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 19-10-2021 в 12:31:01 2



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.