Code-Enjoy

ЕГЭ по информатике 2025 - Задание 14 (Чемпионская подготовка)



Мы подошли к 14 заданию из ЕГЭ по информатике 2025. Оно связано с различными системами счисления. Что такое различные системы счисления, мы рассматривали в этой статье. Так же будет полезно посмотреть эту статью.


Переходим к первому тренировочному 14-ому заданию из ЕГЭ по информатике.





Задача (ЕГЭ по информатике, 2024)

Значение арифметического выражения 3100 - x, где х — целое положительное число, не превышающее 2030, записали в троичной системе счисления. Определите наибольшее значение х, при котором в троичной записи числа, являющегося значением данного арифметического выражения, содержится ровно пять нулей.

В ответе запишите число в десятичной системе счисления.


Решение:

Напишем программу на языке Python.


for x in range(1, 2031):
    
    f = 3**100 - x
    #Счётчик нулей в троичной системе
    k=0

    #Перебираем цифры в троичной системе
    while f>0:
        if f%3==0:
            k += 1
        f = f // 3   
    
    if k==5:
        print(x)

В программе "крутим" переменную x в цикле for. Для каждого x получаем f = 3100 - x. Заводим счётчик k, который будет подсчитывать количество нулей нашего числа в троичной системе.


Далее перебираем цифры в троичной системе так же, как мы делали в 9 классе на листке бумаги. Остаток от деления на 3 - это и есть очередная цифра в троичной системе. Но нужно так же переменную f целочисленно делить на 3, иначе будем получать одну и ту же цифру. Так же отметим, что цифры числа f в троичной системе получаем с конца.


Если очередная цирфа является нулём, засчитываем её в переменную k.


После того, как цикл while отработает, можно проверять значение счётчика k. Если там получилось пять нулей, то печатаем значение x, при котором это произошло.


Ответ: 2024



Задача (Классика)

Значение выражения 536 + 524 - 25 записали в системе счисления с основанием 5. Сколько цифр "4" содержится в этой записи?


Решение:

f = 5**36 + 5**24 - 25
k=0

while f>0:
    if f%5==4:
        k += 1
    f = f // 5

print(k)

В переменную f записываем арифметическое выражение. Две звёздочки подряд обозначают возведение в степень. Заводим переменную k, которая будет отвечать за ответ.


Сам перевод числа f в пятеричную систему происходит в цикле WHILE.


Вычисляем остатки от деления на 5. Очередная цифра в 5-ричной системе, это и есть остаток при делении f на 5. Если очередной остаток равен нужной цифре "4", то мы прибавляем счётчик k. Так же производим целочисленное деление на 5, чтобы остатки менялись. Алгоритм точно такой же, как если бы переводили на листке бумаги делением уголком.


Продолжая данный алгоритм, в переменной f будет рано или поздно 0.


Важно понимать, что в начале у нас идёт последняя цифра в пятиричной системе, при следующем проходе цикла - предпоследняя и т.д.


В ответе напишем 22.


Ответ: 22



Задача (Классика, количество цифр, превышающих 9)

Определите количество цифр с числовым значением, превышающим 9, в 27-ричной записи числа, заданного выражением: 2∙7292014 + 2∙2432016 - 2∙812018 + 2∙272020 - 2∙92022 - 2024.


Решение:
f = 2*729**2014 + 2*243**2016 - 2*81**2018 + 2*27**2020 - 2*9**2022 - 2024
k=0

while f>0:
    if f%27 > 9:
        k += 1
    f = f // 27

print(k)

Решение почти такое же, как в прошлой задаче, но теперь мы подсчитываем только те цифры, которые больше 9.


Ответ: 2687



Задача (Классика, сумма цифр)

Значение арифметического выражения 51∙712 - 73 - 22 записали в системе счисления с основанием 7. В этой записи найдите сумму цифр с числовым значением, превышающим 3.


Решение:
f = 51*7**12 - 7**3 - 22
sm = 0

while f>0:
    if f%7 > 3:
        sm = sm + (f%7)
    f = f // 7

print(sm)


Здесь решение похоже на предыдущую задачу. Мы заводим переменную sm, где по итогу должен получится ответ. Суммируем только те цифры в семеричной системе, которые больше трёх.


Ответ: 65



Задача (Классика, второй тип)

В выражении 1xBAD16 + 2CxFE16 x обозначает некоторую цифру из алфавита шестнадцатеричной системы счисления. Определите наименьшее значение x, при котором значение данного выражения кратно 15. Для найденного x вычислите частное от деления данного выражения на 15 и запишите его в ответе в десятичной системе счисления.


Решение:

Здесь дана сумма чисел, которые написаны в шестнадцатеричной системе счисления.


Мы будем перебирать каждую цифру из шестнадцатеричной системы (0-15) с помощью цикла. Нас будут интересовать те значения x, при котором сумма этих чисел будет делится на 15.


for x in range(0, 16):
    a=13*16**0 + 10*16**1 + 11*16**2 + x*16**3 + 1*16**4
    b=14*16**0 + 15*16**1 + x*16**2 + 12*16**3 + 2*16**4
    if (a+b)%15==0:
        print(x, (a+b)//15)

Чтобы проверить, делится ли данное выражение на 15, переводим оба слагаемых в нашу родную десятичную систему. Переводим стандартным образом, об этом можно прочитать здесь.


В задаче нужно написать для наименьшего найденного значения x результат от деления данной суммы на 15.


Получается 18341


Ответ: 18341



Задача(Классика, второй тип, закрепление)

(Богданов) Операнды арифметического выражения записаны в системе счисления с основанием 17:


9759x17 + 3x10817

В записи чисел переменной x обозначена неизвестная цифра из алфавита 17-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратного 11. Для найденного значения x вычислите частное от деления значения арифметического выражения на 11 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.


Решение:

Решим задание с помощью предыдущего шаблона на языке Python.


for x in range(0, 17):
    a=x*17**0 + 9*17**1 + 5*17**2 + 7*17**3 + 9*17**4
    b=8*17**0 + 0*17**1 + 1*17**2 + x*17**3 + 3*17**4
    if (a+b)%11==0:
        print(x, (a+b)//11)

Ответ: 95306



Задача (Классика, второй тип, две переменные)

Числа M и N записаны в системах счисления с основаниями 15 и 13 соответственно.

M = 2y23x515, N = 67x9y13

В записи чисел переменными x и y обозначены допустимые в данных системах счисления неизвестные цифры. Определите наименьшее значение натурального числа A, при котором существуют такие x, y, что M + A кратно N.


Решение:

Принцип решения данной задачи похож на решение 15 задания из ЕГЭ по информатике.


for A in range(1, 5000):
    for x in range(0, 13):
        for y in range(0, 13): 
            M=5*15**0 + x*15**1 + 3*15**2 + 2*15**3 + y*15**4 + 2*15**5
            N=y*13**0 + 9*13**1 + x*13**2 + 7*13**3 + 6*13**4
            if (M+A)%N==0:
                print(A)

Нужно найти A, значит, начинаем перебирать эту переменную в цикле. Идём от 1, т.к. речь идёт о натуральных числах. Перебираем x и y. Они могут принимать значения из алфавита в 13-ой системе. Берём наименьшую систему, т.к. эти переменные есть и в первом числе, и во втором числе.


Если выполняется условие задачи, то нам интересно такое A, при котором это произошло.


В этой задаче A получается достаточно большим, поэтому перебираем эту переменную до 5000.


Ответ: 1535



Задача (Тренировочная)

Укажите через запятую в порядке возрастания все десятичные натуральные числа, не превосходящие 17, запись которых в троичной системе счисления оканчивается на две одинаковые цифры.


Решение:
for i in range(3, 18):
    
    # Последняя цифра в троичной системе
    last1 = i % 3

    # Предпоследняя цифра в троичной системе
    x = i
    x = x // 3
    last2 = x % 3

    if last1 == last2:
        print(i)

Остаток от деления на 3 - это и есть последняя цифра в троичной системе. Чтобы найти предпоследнюю цифру в троичной системе, нужно поделить целочисленно наше число i на 3, потом вновь найти остаток от деления.


Мы используем вспомогательную переменную x, чтобы не изменять значение первоначального числа i. Если выполняется условие задачи, печатаем i, при котором это произошло.


Начинаем перебор цикла с 3, т.к. именно с этого числа представление в троичной системе будет содержать минимум 2 разряда.


Ответ: 4, 8, 9, 13, 17



Ещё один интересный тип задания номер 14, который вполне может быть на реальном ЕГЭ по информатике 2025.


Задача (Уравнение)

Чему равно наименьшее основание позиционной системы счисления x, при котором 225x = 405y? Ответ записать в виде целого числа.


Решение:

Решим данную задачу через Python.


for x in range(2, 1000):
    for y in range(2, 1000):
        a = 5*x**0 + 2*x**1 + 2*x**2
        b = 5*y**0 + 0*y**1 + 4*y**2
        if a == b: 
            print(x)

Прокрутим переменные x и y в циклах в примерном диапазоне. Внутри вложенных циклов переведём одно и второе число по правилам 9 класса в десятичную систему. Если числа окажутся равны, печатаем такое значение x, при котором это произошло.


Наименьшее значение равно 8.


Ответ: 8



Для качественной проработки 14 задания из ЕГЭ по информатике 2025 разберём ещё некоторые задачи.


Задача (На понимание)

Запись числа в девятеричной системе счисления заканчивается цифрой 4. Какой будет последняя цифра в записи этого числа в троичной системе счисления?


Решение:
for i in range(1, 100):
    if i%9==4:
        print(i, i%3)

Используем то, что последняя цифра числа в какой-то системе счисления - это и есть остаток от деления этого числа на основание данной системы.


Ответ: 1



Продолжаем подготовку к 14 заданию из ЕГЭ по информатике 2025


Задача (Закрепление материала)

Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 23 оканчивается на 2.


Решение:

Нужно перебрать все числа от 3 до 23 и определить, какие из них при делении числа 23 дадут остаток 2.


23 : 3 = 7 (ост. 2) +
23 : 4 = 5 (ост. 3) -
23 : 5 = 4 (ост. 3) -
23 : 6 = 3 (ост. 5) -
23 : 7 = 3 (ост. 2) +
23 : 8 = 2 (ост. 7) -
23 : 9 = 2 (ост. 5) -
23 : 10 = 2 (ост. 3) -
23 : 11 = 2 (ост. 1) -
23 : 12 = 1 (ост. 11) -
23 : 13 = 1 (ост. 10) -
23 : 14 = 1 (ост. 9) -
23 : 15 = 1 (ост. 8) -
23 : 16 = 1 (ост. 7) -
23 : 17 = 1 (ост. 6) -
23 : 18 = 1 (ост. 5) -
23 : 19 = 1 (ост. 4) -
23 : 20 = 1 (ост. 3) -
23 : 21 = 1 (ост. 2) +
23 : 22 = 1 (ост. 1) -
23 : 23 = 1 (ост. 0) -

Подходят числа 3, 7, 21.


Здесь можно и написать программу:


for n in range(3, 24):
    if 23%n==2:
        print(n)

Ответ: 3, 7, 21



Задача (Добьём 14 задание из ЕГЭ по информатике 2025)

В некоторой системе счисления записи десятичных чисел 66 и 40 заканчиваются на 1. Определите основание системы счисления.


Решение:

Нужно найти такое число, чтобы числа 66 и 40 при делении на него давали остаток 1. Первый остаток при делении на основание системы - это и есть последняя цифра числа в этой системе счисления.


Т.е. искомое число должно быть делителем чисел 65 (66-1) и 39 (40-1). У числа 39 не так много делителей: 1, 3, 13, 39


Видим, что число 65 делится на 13 (65 : 13 = 5). Поэтому искомое число равно 13.


Решим на Python.


for n in range(2, 100):
    if 66%n==1 and 40%n==1:
        print(n)

Ответ: 13



Задача (Для чемпионов!)

В какой системе счисления выполняется равенство 12 · 13 = 222?
В ответе укажите число – основание системы счисления.


Решение:

Если бы мы находились в десятичной системе, то последней цифрой была бы 6 (2 * 3). Но у нас 2! Т.е. cистема счисления меньше или равна 6, т.к. если бы система счисления была больше 6, то у нас была бы 6 последняя цифра.


Шестёрка не "поместилась" в младший разряд, от неё осталось только 2. Остальные 4 единицы ушли в более старший разряд. Если 4 единицы составляют единицу более старшего разряда, то значит, мы находимся в четверичной системе.


Ответ: 4



Задача (Основание системы)

Запись числа 338 в системе счисления с основанием N содержит 3 цифры и оканчивается на 2. Чему равно максимально возможное основание системы счисления?


Решение:

В этой задаче применим формулу:


ЕГЭ по информатике 2022 - задание 14 (Формула)

Примером для данной формулы можно взять два разряда в двоичной системе. Максимальное число в двоичной системе равно 112. А в десятичной системе это число равно 310. Т.е. 22 - 1.


338 число будет точно больше, чем двухзначное число с основанием N.


Получается неравенство:


338 > N2 - 1
N2 < 339


N - положительное целое число. Тогда:


N < √339 ≈ 18,4
N ≤ 18




Сказано, что число в системе с основанием N оканчивается на 2. Поэтому первый остаток должен быть равен 2!


ЕГЭ по информатике 2021 - задание 14 (Число оканчивается на 2)

Будем идти вниз от числа 18 и проверять, на что делится 336.


Число 336 должно делится на N.


Подошло число 16 (16 * 21 = 336!)


Ответ: 16

На этом всё! Вы прошли чемпионскую тренировку по 14 заданию из ЕГЭ по информатике 2025. Успехов на экзамене!






01-08-2024 в 13:41:18






Поддержать сайт:


Похожая статья:

Досрочный ЕГЭ по информатике 2023 (Задания 11-21)

Продолжаем разбирать задачи из досрочного ЕГЭ по информатике 2023....

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 10-04-2023 в 15:00:22 5



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.