Всемирный день риса

Разбор демоверсии ОГЭ по информатике 2023. Часть 2



Приступим ко второй части из ОГЭ по информатике демоверсии 2023.


Вторую часть нужно делать на компьютере.



Источник заданий: https://fipi.ru/oge/demoversii-specifikacii-kodifikatory#!/tab/173801626-5



Разбор первой части демоверсии ОГЭ по информатике 2023

Вторую часть рекомендую начинать решать с 12 задания. Потому что в 11 задании поиск нужно осуществлять внути файлов, а в 12 задании только по именам. Операционная система сможет проиндексировать содержимое файлов, и тогда не так просто будет искать по именам, т.к. будут подмешиваться результаты, если совпадание будет внутри файлов.


Но разбор будем вести по порядку.





Задание 11

В одном из произведений А.П. Чехова, текст которого приведён в подкаталоге каталога Проза, героиня произносит такую фразу: «Сегодня я в мерехлюндии, невесело мне, и ты не слушай меня». С помощью поисковых средств операционной системы и текстового редактора или браузера выясните имя этой героини.


Скачать файл


Решение:

Открываем каталог Проза. Настроим поиск, чтобы система искала и внутри файлов. Нажмём на кнопку Упорядочить -> Изменить параметры папок и поиска.


ОГЭ по информатике 2023 Задание 11 - настройка поиска




Переходим на вкладку Поиск


ОГЭ по информатике 2023 Задание 11 - настройка поиска 2

Галочка "Не использовать индекс при поиске системных файлов в папках (поиск может работать медленее)" должна стоять при решении и 11 задания, и 12 задания.


При решении 11 задания мы должны поставить галочку "Всегда искать по именам файлов и содержимому (может занять несколько минут)". Так мы сможем искать не только по именам, но и по содержимому файла.


В правом углу пропишем фразу, которую говорила героиня: "Сегодня я в мерехлюндии, невесело мне, и ты не слушай меня". И нажмём Enter.


ОГЭ по информатике 2023 Задание 11 - поиск строки

Получим два файла:





ОГЭ по информатике 2023 Задание 11 - результаты поиска

Открываем файлы по очереди. Нажимаем Ctrl + F (Поиск) и вбиваем фразу в строку поиска уже в той программе, с помощью которой открылся данный файл. Пытаемся найти имя героини, которая произнесла эту фразу.


В первом файле находим, что её имя МАША.


ОГЭ по информатике 2023 Задание 11 - ищем ответ

Ответ: МАША



Задание 12

Сколько файлов с расширением .txt содержится в подкаталогах каталога Проза? В ответе укажите только число.


Скачать файл

Решение:

Открываем настройки поиска, как в прошлом задании, и убираем галочку "Всегда искать по именам файлов и содержимому (может занять несколько минут)". Теперь нам нужно искать только по именам.


ОГЭ по информатике 2023 Задание 12 - настройка поиска

В строке поиска пропишем маску: *.txt. Это обозначает, что название файлов можем быть любое, но расширение должно быть .txt.


Проводник выдаст 1 файл данного расширения.


Ответ: 1



Задание 13

В 13 задании даётся на выбор две задачи. Мы сделаем 13.2 (Работа с текстовым редактором). Будем работать в программе Word.


Создайте в текстовом редакторе документ и напишите в нём следующий текст, точно воспроизведя всё оформление текста, имеющееся в образце.

Данный текст должен быть набран шрифтом размером 14 пунктов обычного начертания. Отступ первой строки первого абзаца основного текста – 1 см. Расстояние между строками текста не менее одинарного, но не более полуторного междустрочного интервала.

Основной текст выровнен по ширине; в ячейках первого столбца таблицы применено выравнивание по левому краю, в ячейках второго и третьего столбцов – по центру. В основном тексте и таблице есть слова, выделенные полужирным, курсивным шрифтом и подчёркиванием. Ширина таблицы меньше ширины основного текста. Таблица выровнена на странице по центру горизонтали.

При этом допустимо, чтобы ширина Вашего текста отличалась от ширины текста в примере, поскольку ширина текста зависит от размеров страницы и полей. В этом случае разбиение текста на строки должно соответствовать стандартной ширине абзаца.

Интервал между текстом и таблицей не менее 12 пунктов, но не более 24 пунктов.

Текст сохраните в файле, имя которого Вам сообщат организаторы. Файл ответа необходимо сохранить в одном из следующих форматов: *.odt, или *.doc, или *.docx.


ОГЭ по информатике 2023 Задание 13 - текстовый фрагмент

Решение:

Перепечатываем весь текст в программе Word. После слова "Углерод" нужно поставить короткое тире. Это можно сделать, нажав Ctrl и минус на правой части клавиатуры. Чтобы поставить длинное тире, мы должны зажать клавиши Ctrl + Alt + минус на правовой части клавиатуры.


Выделяем весь текст и выбираем размер шрифта в 14pt.


ОГЭ по информатике 2023 Задание 13 - устанавливаем размер шрифта




Снова выделяем весь текст и нажимаем на параметры абзаца (на рисунке показано):


ОГЭ по информатике 2023 Задание 13 - параметры абзаца

Для первой строки устанавливаем Отступ на 1 см.


ОГЭ по информатике 2023 Задание 13 - отступ первой строки




Выделяем текст. Расстояние между строками текста устанавливаем в 1.


ОГЭ по информатике 2023 Задание 13 - отступ первой строки

Выделим весь текст и сделаем его по ширине.


ОГЭ по информатике 2023 Задание 13 - текст по ширине

Вставим таблицу. Переходим на вкладку Вставить. Нажимаем на чёрный треугольник возле кнопки Таблица. Выбираем таблицу с тремя столбцами и тремя строками.


ОГЭ по информатике 2023 Задание 13 - вставляем таблицу

Пропишем весь текст в таблицу. Текст кг/м3 можно написать с помощью кнопки Надстрочный. Мы выделяем тройку и нажимаем на эту кнопку.


ОГЭ по информатике 2023 Задание 13 - надстрочный текст



Символ градусов °C можно найти: Вставка -> Символ -> Другие символы


ОГЭ по информатике 2023 Задание 13 - вставляем градусы

Там можно найти кружочек, а символ C поставить с клавиатуры.





Если подвести к левому верхнему краю, появится крестик из стрелочек.


ОГЭ по информатике 2023 Задание 13 - свойство таблицы

Нажмём правую кнопку мыши и выберем Свойства таблицы.


ОГЭ по информатике 2023 Задание 13 - свойство таблицы 2




Выделим левый столбец и нажмём на кнопку "Выровнять по левому краю". Два других столбца аналогично выравниваем по центру.


ОГЭ по информатике 2023 Задание 13 - выровнять по левому краю




Отметим некоторые слова жирным, курсивом или подчёркиванием, как показано в образце.


Чтобы сделать нужный интервал между таблицей и абзацем, нужно зайти вновь в параметры абзаца. Делаем интервал после абзаца в 12 pt.


ОГЭ по информатике 2023 Задание 13 - свойства абзаца

Вот, что в итоге получилось:


ОГЭ по информатике 2023 Задание 13 - результат




Задание 14

В электронную таблицу внесли данные о тестировании учеников по выбранным ими предметам.


ОГЭ по информатике 2023 Задание 14 - условие

В столбце A записан код округа, в котором учится ученик; в столбце B – код фамилии ученика; в столбце C – выбранный учеником предмет; в столбце D – тестовый балл.

Всего в электронную таблицу были внесены данные о 1000 учеников.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, выполните задания.


  1. Сколько учеников, которые проходили тестирование по информатике, набрали более 600 баллов? Ответ запишите в ячейку H2 таблицы.
  2. Каков средний тестовый балл учеников, которые проходили тестирование по информатике? Ответ запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.
  3. Постройте круговую диаграмму, отображающую соотношение числа участников тестирования из округов с кодами «В», «Зел» и «З». Левый верхний угол диаграммы разместите вблизи ячейки G6. В поле диаграммы должны присутствовать легенда (обозначение соответствия данных определённому сектору диаграммы) и числовые значения данных, по которым построена диаграмма.

Полученную таблицу необходимо сохранить под именем, указанным организаторами экзамена.


Скачать файл

Решение:

Открываем файл Excel. Составим формул для одной строки, а потом её распространим на отсланые строки.


Кликаем в ячейку E2. Нажимаем кнопку "Вставить функцию".


ОГЭ по информатике 2023 Задание 14 - кнопка вставить функцию

Выберем функцию ЕСЛИ. В поле Лог_выражение напишем: "И(C2="Информатика"; D2>600)", в поле Значение_если_истина: 1, в поле Значение_если_ложь:0.


ОГЭ по информатике 2023 Задание 14 - функция ЕСЛИ

Чтобы распространить формулу на все строки, подводим курсор мыши к правому нижнему углу ячейки E2, ждём, когда загорится чёрный крестик, нажимаем левую кнопку мыши и тянем вниз.


ОГЭ по информатике 2023 Задание 14 - распространяем формулу

Сумма единиц в столбце E покажет ответ на первый вопрос задачи.


ОГЭ по информатике 2023 Задание 14 - ответ к первому впоросу

Ответ к первому вопросу: 32





Чтобы ответить на второй вопрос, включим фильтр к столбцу С. Выделим столбец С и включим фильтр, как показано на рисунке на вкладке Главная.


ОГЭ по информатике 2023 Задание 14 - включаем фильтр

Отфильтруем людей только тех, кто сдаёт информатику.


ОГЭ по информатике 2023 Задание 14 - отфильтровываем информатику

Внизу можно посмотреть среднее значение выделенных ячеек.


ОГЭ по информатике 2023 Задание 14 - ответ ко второму вопросу

Ответ ко второму вопросу получается 546,82


Построим круговую диаграмму для третьего вопроса. Для этого нужно узнать количество участников из округов с кодами «В», «Зел» и «З». Это сделаем опять с помощью фильтров. Отфильтруем участников из каждого округа, выделем столбец с участниками и внизу программа покажет количество выделенных ячеек (программа показывает количество выделенных ячеек, не строчек). Потом мы должны написать вот такую таблицу с полученными данными.


ОГЭ по информатике 2023 Задание 14 - таблица для 3 вопроса

Выделяем эту таблицу нажимаем вкладку Вставить -> Диаграммы, выбираем круговую диаграмму. Нажмём на "плюсик", который расположен в правом верхнем углу и выберем метки данных. Должна получится примерно вот такая диаграмма:


ОГЭ по информатике 2023 Задание 14 - круговая диаграмма

Эту диаграмму можно перемещать в нужное место.


В 15 задании выберем задачу 15.2





Задание 15

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4, но не кратных 7. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и не кратное 7. Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число: количество чисел, кратных 4, но не кратных 7.


ОГЭ по информатике 2023 Задание 15

Решение:

Решим на языке Python.


n=int(input())

k=0

for i in range(n):
    a = int(input())
    if a%4==0 and a%7!=0:
        k=k+1

print(k)

В переменную n пользователь вводит сначала количество чисел в последовательности. Переменная k это и есть счётчик, который подсчитывает нужные числа в последовательности.


Далее идёт цик for. Он будет повторяться n раз. Внутри цикла запрашивается очередное число a. Если оно делится на 4 и не делится на 7, то мы подсчитываем это число. В конце печатаем переменную k.



Разбор первой части демоверсии ОГЭ по информатике 2023




24-08-2022 в 13:09:01





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2021 - Задание 20 (Юбилейный выпуск!)

Продолжаем решать задачи на теорию игр. Сегодня у нас разбор 20 задани...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 01-12-2020 в 21:00:43 0


Комментарии:

В 15-м задании правильный ответ по примеру - 3 (4, 16, 24)
Евгений 06-12-2022 в 15:00:58

Евгений, 4 - это количество чисел, это число не является числом последовательности.
Калужский Александр 07-12-2022 в 09:59:42

Спасибо:3
Даша 31-05-2023 в 13:58:23



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.