Code-Enjoy

ОГЭ по информатике ДЕМО 2025 (Часть 2)



Продолжаем разбор ОГЭ по информатике 2025! В этой статье разберём вторую часть.


Приступим у решению.


Вторую часть нужно делать на компьютере.




Разбор первой части демоверсии ОГЭ по информатике 2025




Задание 11

В одном из произведений А.П. Чехова, текст которого приведён в подкаталоге каталога Проза, присутствует эпизод, в котором щенок, «взятый приучаться», услышал выстрел и поджал хвост. С помощью поисковых средств операционной системы и текстового редактора выясните кличку этого щенка.


Скачать файл

Решение:

Открываем каталог Проза. Настроим поиск, чтобы система искала и внутри файлов. Нажмём на кнопку Упорядочить -> Изменить параметры папок и поиска.


ОГЭ по информатике 2025 Задание 11 - настройка поиска


Переходим на вкладку Поиск


ОГЭ по информатике 2025 Задание 11 - настройка поиска 2




Галочка "Не использовать индекс при поиске системных файлов в папках (поиск может работать медленнее)" должна стоять при решении и 11 задания, и 12 задания.


При решении 11 задания мы должны поставить галочку "Всегда искать по именам файлов и содержимому (может занять несколько минут)". Так мы сможем искать не только по именам, но и по содержимому файла.


В правом углу пропишем фразу: "взятый приучаться". И нажмём Enter.


ОГЭ по информатике 2025 Задание 11 - поиск в тексте

В папке отобразятся следующие файлы:


ОГЭ по информатике 2025 Задание 11 - результаты поиска

Открываем первый файл. Нажимаем Ctrl + F (Поиск) и вбиваем эту же фразу в строку поиска. Программа может ничего не найти. Тогда попробуем найти только одно слово "приучаться".


Программа выведет нужный нам фрагмент.


ОГЭ по информатике 2025 Задание 11 - поиск клички щенка

Кличка щенка: Тщетный.


Ответ: Тщетный



Задание 12

Сколько файлов c расширением .htm содержится в подкаталогах Есенин и Лермонтов каталога DEMO-12/Поэзия? В ответе укажите только число.


Скачать файл
Решение:

Открываем настройки поиска, как в прошлом задании, и убираем галочку "Всегда искать по именам файлов и содержимому (может занять несколько минут)". Теперь нам нужно искать только по именам.


ОГЭ по информатике 2025 Задание 12 - настройка поиска

В начале переходим в подкаталог Поэзия/Есенин.


В строке поиска пропишем маску: *.htm. Это обозначает, что название файлов может быть любым, но расширение должно быть .htm.





Проводник выдаст 3 файл данного расширения. Количество найденных файлов можно посмотреть в левом нижним углу.


ОГЭ по информатике 2025 Задание 12 - результаты поиска


Обратите внимание, что при такой маске так же могли отобразиться файлы с расширением .html. В этом случае можно глазами найти файлы с расширением .html и не засчитывать их. Так же можно отдельно найти количество файлов с расширением .html с помощью маски *.html и вычесть их из общего количества.

Аналогично действуем и для подкаталога Поэзия/Лермонтов. Там тоже получается 3 файла.


Ответ получается


3 + 3 = 6

Ответ: 6

В 13 Задании у нас есть выбор между созданием презентации и форматированием текстового документа. Мы выберем второй вариант. Будем работать в программе Word.





Задание 13

Создайте в текстовом редакторе документ и напишите в нём следующий текст, точно воспроизведя всё оформление текста, имеющееся в образце.

Данный текст должен быть написан шрифтом размером 14 пунктов. В тексте и в таблице есть слова, выделенные полужирным шрифтом и курсивом. Заголовок текста набран прописными буквами. Отступ первой строки первого абзаца 1 см. Расстояние между строками текста не менее высоты одинарного, но не более полуторного междустрочного интервала. Основной текст выровнен по ширине, заголовок текста – по центру. В ячейках первой строки таблицы применено выравнивание по центру горизонтали, в ячейках первого столбца таблицы, кроме заголовка, текст выровнен по левому краю, в остальных ячейках таблицы – по центру. Ширина таблицы меньше ширины основного текста. Таблица выровнена на странице по центру горизонтали.

При этом допустимо, чтобы ширина Вашего текста отличалась от ширины текста в примере, поскольку ширина текста зависит от размера страницы и полей. В этом случае разбиение текста на строки должно соответствовать стандартной ширине абзаца.

Интервалы между заголовком, текстом и таблицей не менее 12 пунктов, но не более 24 пунктов.

Текст сохраните в файле, имя которого Вам сообщат организаторы экзамена. Файл ответа необходимо сохранить в одном из следующих форматов: *.odt, или *.doc, или *.docx.


ОГЭ по информатике Демо 2025 Задание 13 - Текст

Решение:

Перепечатываем весь текст в программе Word. После слова "океан" нужно поставить короткое тире. Это можно сделать, нажав Ctrl и минус на правой части клавиатуры. Чтобы поставить длинное тире, мы должны зажать клавиши Ctrl + Alt + минус на правовой части клавиатуры.


ОГЭ по информатике Демо 2025 Задание 13 - переписываем текст




Название нужно выровнять по центру. Выделяем "АТЛАНТИЧЕСКИЙ ОКЕАН" и нажимаем "Выровнять по центру".


ОГЭ по информатике Демо 2025 Задание 13 - выровнять по центру

Выделяем весь текст и выбираем размер шрифта в 14pt.


Снова выделяем весь текст и нажимаем на параметры абзаца (на рисунке показано):


ОГЭ по информатике Демо 2025 Задание 13 - настройки абзаца




Для первой строки устанавливаем Отступ на 1 см.


ОГЭ по информатике 2025 Задание 13 - отступ первой строки

Выделим текст. Расстояние между строками текста устанавливаем в 1.


ОГЭ по информатике 2025 Задание 13 - межстрочный интервал




Выделим абзац и выровним его по ширине.


ОГЭ по информатике 2025 Задание 13 - выровнять по ширине

Вставим таблицу. Переходим на вкладку Вставить. Нажимаем на чёрный треугольник возле кнопки Таблица. Выбираем таблицу с двумя столбцами и пятью строками.


ОГЭ по информатике 2025 Задание 13 - выровнять по ширине




Выделим в первой строке ячейки, вызовем контекстное меню правой кнопкой мыши и нажмём "Объединить ячейки".


ОГЭ по информатике 2025 Задание 13 - выровнять по ширине

Пропишем весь текст в таблицу. Например, текст км2 можно написать с помощью кнопки Надстрочный. Мы выделяем двойку и нажимаем на эту кнопку.


ОГЭ по информатике 2025 Задание 13 - выровнять по ширине

Выровним первую строку в талице по центру, для левого столбца оставим выравнивание по левому краю, для правого столбца применим выравнивание по центру.





Если подвести к левому верхнему краю таблицы, появится крестик из стрелочек.


ОГЭ по информатике 2025 Задание 13 - настройки таблицы

Нажмём правую кнопку мыши и выберем Свойства таблицы.


ОГЭ по информатике 2025 Задание 13 - настраиваем ширину таблицы

Отметим некоторые слова жирным, курсивом или подчёркиванием, как показано в образце. Для этого есть специальные кнопки на главной вкладке (Ж К Ч).


Выделим ещё раз весь текст и сделаем шрифт 14pt, как сказано в задании.





Чтобы сделать интервалы между заголовком, текстом и таблицей не менее 12 пунктов, но не более 24 пунктов, выделяем заголовок и первый абзац и вновь заходим в параметры абзаца.



ОГЭ по информатике 2025 Задание 13 - свойства абзаца

Вот что в итоге получилось:


ОГЭ по информатике 2025 Задание 13 - результат




Задание 14

В электронную таблицу внесли результаты анонимного тестирования. Все участники набирали баллы, выполняя задания для левой и правой руки. Ниже приведены первые строки получившейся таблицы.


ОГЭ по информатике 2025 Задание 14 - таблица

В столбце A указан номер участника, в столбце B – пол, в столбце C – один из трёх статусов: пенсионер, служащий, студент; в столбцах D, E – показатели тестирования для левой и правой руки.

Всего в электронную таблицу были внесены данные 1000 участников. Порядок записей в таблице произвольный.


Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, выполните задания.


1. Сколько женщин-пенсионеров участвовало в тестировании? Ответ на этот вопрос запишите в ячейку G2 таблицы.


2. Какова разница между максимальным и минимальным показателями для правой руки? Ответ на этот вопрос запишите в ячейку G3 таблицы.


3. Постройте круговую диаграмму, отображающую соотношение количества женщин-пенсионеров, женщин-студентов и женщин- служащих. Левый верхний угол диаграммы разместите вблизи ячейки G6. В поле диаграммы должны присутствовать легенда (обозначение, какой сектор диаграммы соответствует каким данным) и числовые значения данных, по которым построена диаграмма.


Полученную таблицу необходимо сохранить под именем, указанным организаторами экзамена.


Скачать файл




Решение:

Решим задачу под пунктом 1. Напишем формулу для первого участника в ячейке F2:


=ЕСЛИ(И(B2="жен";C2="пенсионер");1;0)

Эта формула поставит 1 в ячейку F2, если этот участник женщина И она пенсионер. Иначе в этой ячейке будет 0.


Распространим эту формулу на весь столбец. Подведём курсор к правому нижнему углу ячейки F2, чтобы появился чёрный крестик. И кликнем два раза по углу этой ячейки. Формула должна распространится на весь столбец.


ОГЭ по информатике 2025 Задание 14 - Распространили формулу

Теперь мы для каждого участника знаем ответ на наш вопрос. Чтобы найти количество, нужно просто посчитать сумму столбца F. Выделим весь столбец, нажав на букву F. В правом нижнем углу программы будет сумма выделенных ячеек. Получается ответ 143.





Ответим на второй вопрос задачи. Мы пока не обращаем внимание на ячейки, куда нужно записать ответы. Результаты мы запишем в самом конце в нужные ячейки.


Найдём максимальное значение для правой руки в ячейке G2. Пропишем там формулу:


=МАКС(E:E)

Получается 79. Аналогично найдём минимальное значение для правой руки в ячейке H2


=МИН(E:E)

Получается 30.


Разница получается 79 - 30 = 49.


В третьем вопросе мы так же, как и в первом вопросе найдём сколько у нас женщин-пенсионеров, женщин-студентов, женщин-служащих.


Количество женщин-пенсионеров мы знаем 143.


Формула для женщин-студентов (можно опять использовать столбец F):


=ЕСЛИ(И(B2="жен";C2="студент");1;0)

Снова распространяем формулу на весь столбец и ищем сумму столбца F. Получается 240.


Формула для женщин-служащих:


=ЕСЛИ(И(B2="жен";C2="служащий");1;0)

Снова распространяем формулу на весь столбец и ищем сумму столбца F. Получается 100.


Теперь формируем мини-таблицу:


ОГЭ по информатике 2025 Задание 14 - мини-таблица




Выделяем эту мини-таблицу, переходим на вкладку Вставка -> Круговая диаграмма.


ОГЭ по информатике 2025 Задание 14 - круговая диаграмма

Нажмём правой кнопкой мыши по диаграмме и выберем "добавить подписи данных".


ОГЭ по информатике 2025 Задание 14 - круговая диаграмма (с подписью данных)

Остаётся разместить в нужное место диаграмму и поставить ответы на первый и второй вопрос в соответствующие ячейки.





Задание 15

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды – это команды-приказы:


вверх вниз влево вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, где Робот находится в настоящий момент.

Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:


сверху свободно снизу свободно слева свободно справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:


  если условие то
  последовательность команд
  все

Здесь условие – одна из команд проверки условия.

Последовательность команд – это одна или несколько любых команд- приказов.

Например, для передвижения на одну клетку вправо, если справа нет стенки и закрашивания клетки, можно использовать такой алгоритм:


  если справа свободно то
  вправо
  закрасить
  все




В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:


  если (справа свободно) и (не снизу свободно) то
  вправо
  все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:


  нц пока условие
  последовательность команд
  кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:


  нц пока справа свободно
  вправо
  кц

Выполните задание.


На бесконечном поле есть горизонтальная и вертикальная стены. Левый конец горизонтальной стены соединён с верхним концом вертикальной стены. Длины стен неизвестны. В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно под горизонтальной стеной у её правого конца.





На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).


ОГЭ по информатике 2025 Задание 15 - начальная позиция

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно ниже горизонтальной стены и правее вертикальной стены. Проходы должны остаться незакрашенными. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).


ОГЭ по информатике 2025 Задание 15 - роботу нужно нарисовать

При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера проходов внутри стен.

Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.

Сохраните алгоритм в формате программы Кумир или в текстовом файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена.





Решение:

Решим задачу в программе Кумир-Стандарт.


Выберем Робот -> Новая обстановка. Выберем размер 10 на 10.


Выберем Робот -> Показать окно исполнителя. Затем, Робот -> Редактировать обстановку.


В появившемся окне можно ставить и убирать стенки с помощью левой кнопки мыши.


Сделаем карту, такую же, как дали в задании. Робота так же можно перенести с помощью левой кнопки мыши.


ОГЭ по информатике 2025 Задание 15 - редактируем обстановку

Пропишем программу:


использовать Робот
алг
нач
  нц пока не сверху свободно
    закрасить
    влево
  кц
  нц пока сверху свободно
    влево
  кц
  нц пока слева свободно
    закрасить
    влево
  кц
  нц пока не слева свободно
    закрасить
    вниз
  кц
  нц пока слева свободно
    вниз
  кц
  нц пока не слева свободно
    закрасить
    вниз
  кц
кон




Получается результат:


ОГЭ по информатике 2025 Задание 15 - результат




Задание 16

Напишите программу для решения следующей задачи.

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру для дней, когда температура поднималась выше нуля градусов. Определите количество таких дней. Гарантируется, что за время наблюдения хотя бы в один из дней температура поднималась выше нуля градусов.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.


Пример работы программы.


Входные данные Выходные данные
4
–5
12
–2
8
10.0
2

Решение:

Решим задачу на языке Python.


# Получаем количество дней наблюдения
n = int(input())
# Инициализируем переменные для хранения суммы температур и количества дней,
# когда температура была больше 0.
sm = 0
k = 0
# Цикл для ввода температур за каждый день
for i in range(n):
    t = int(input())

# Проверяем, если температура выше нуля
    if t > 0:
        sm += t  # Добавляем температуру к общей сумме
        k += 1  # Увеличиваем счетчик дней с температурой выше нуля

# Вычисляем среднюю температуру  для тех дней, когда температура больше нуля
sr = sm/k

print(sr)
print(k)


Разбор первой части демоверсии ОГЭ по информатике 2025


На этом всё! Удачи на ОГЭ по информатике 2025.





25-08-2024 в 10:30:42






Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2021 - Задание 3 (База данных)

Пришло время 3 задания из ЕГЭ по информатике 2021...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 26-08-2020 в 19:02:17 4



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.