Code-Enjoy

ЕГЭ по информатике ДЕМО 2025 - Задания 1-7



Привет! В этой статье решим новый демонстрационный вариант ЕГЭ по информатике 2025.


В этой части посмотрим задания с 1-ого по 7-ое.


При решении будем опираться на НОВЫЙ бесплатный курс для подготовки к ЕГЭ по информатике 2025.


Разбор демоверсии ЕГЭ по информатике 2025 (8-14 Задания)
Разбор демоверсии ЕГЭ по информатике 2025 (15-21 Задания)
Разбор демоверсии ЕГЭ по информатике 2025 (22-27 Задание)

В демонстрационном варианте представлены три примера задания 14 и два примера задания 25. В реальных вариантах экзаменационной работы на позициях 14 и 25 будет предложено только одно задание.


Приступим!





Задание 1

На рисунке схема дорог N-ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).


ЕГЭ по информатике демо 2025 Задание 1 - карта городов

Так как таблицу и схему рисовали независимо друг от друга, нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова сумма протяжённостей дорог из пункта D в пункт G и из пункта A в пункт C.


В ответе запишите целое число.


Решение:

Здесь нужно попытаться разгадать, под каким номер идёт тот или иной город.


Точка E является "двойной" точкой (т.е. к ней идёт две дороги), но она не соединена с другими "двойными" городами.


Получается, что точка E - это 7.





Пойдём по соседям города E. Город под номером 1, у него есть в соседях "двойной" город 4, следовательно 1 - С, а 4 - это A.


ЕГЭ по информатике демо 2025 Задание 1 - карта городов (Решение)

Тогда второй сосед города E будет городом F. Получается, что 3 - F.


Город G имеет связи и с F, и с C. Значит, 5 - G, а оставшийся "тройной" город - это D. Получается, что 6 - D.


ЕГЭ по информатике демо 2025 Задание 1 - карта городов (Решение) 2

Тогда,


DG + AC = 8 + 30 = 38

Ответ: 38



Задание 2

Миша заполнял таблицу истинности логической функции F


((w → y) → x) ∨ ¬z,

но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.


ЕГЭ по информатике демо 2025 - Задание 2 (таблица)

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.


В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.


Пример. Функция F задана выражением ¬x ∨ y, зависящим от двух переменных, а фрагмент таблицы имеет следующий вид.


ЕГЭ по информатике демо 2025 - Задание 2 (пример)

В этом случае первому столбцу соответствует переменная y, а второму столбцу – переменная x. В ответе следует написать: yx.


Решение:

Решим задачку с помощью шаблона на языке Python, о котором мы говорили в статье из нового курса ЕГЭ по информатике 2025.


print('x y z w')
for x in range(0, 2):
    for y in range(0, 2):
        for w in range(0, 2):
            for z in range(0, 2):
                if not( (not(not(w) or y) or x) or not(z) ):
                    print(x, y, z, w)

Как переписать функцию во 2 Задании из ЕГЭ по информатике, опять же читайте в статье (там есть и видеоурок).


ЕГЭ по информатике демо 2025 - Задание 2 (решение)




Переменная z может быть только в первом столбце, т.к. в остальных столбцах есть хотя бы один ноль. Тогда переменная x может быть только в последнем столбце.


ЕГЭ по информатике демо 2025 - Задание 2 (решение) 2

Так же у нас есть строка, в которой две единицы. Одна единица принадлежит переменной z, но вот вторая переменной y. Значит, во втором столбце будет переменная y.


Третий столбец достаётся w.


Ответ: zywx



Задание 3

В файле приведён фрагмент базы данных «Кондитерские изделия» о поставках конфет и печенья в магазины районов города. База данных состоит из трёх таблиц.

Таблица «Движение товаров» содержит записи о поступлении товаров со склада в магазины в течение августа 2023 г., а также информацию о проданных товарах. Поле Тип операции содержит значение Поступление или Продажа, а в соответствующее поле Количество упаковок, шт. внесена информация о том, сколько упаковок товара поступило в магазин или было продано по итогам дня. Заголовок таблицы имеет следующий вид.


ЕГЭ по информатике демо 2025 - Задание 3 (таблица 1)

Таблица «Товар» содержит информацию об основных характеристиках каждого товара. Заголовок таблицы имеет следующий вид.


ЕГЭ по информатике демо 2025 - Задание 3 (таблица 2)

Таблица «Магазин» содержит информацию о местонахождении магазинов.

Заголовок таблицы имеет следующий вид.


ЕГЭ по информатике демо 2025 - Задание 3 (таблица 3)




На рисунке приведена схема указанной базы данных.


ЕГЭ по информатике демо 2025 - Задание 3 (таблица 4)

Используя информацию из приведённой базы данных, определите общую массу (в кг) всех видов зефира, полученных магазинами, расположенными на проспекте Революции, за период со 2 по 10 августа включительно. В ответе запишите только число.


Скачать файл

Решение:

Откроем файл Excel. Перейдём на вкладку Магазины. Выделим всю таблицу и включим фильтр.


Выбираем кнопку на вкладке "Главная" -> Сортировка и фильтр -> Фильтр.


Задание 3 досрочный ЕГЭ по информатике ДЕМО 2025 - решение через фильтры

Кнопка Фильтр может находится и на главной панели.





Возле таблиц появятся треугольники выбора. Выберем нужную улицу.


ЕГЭ по информатике ДЕМО 2025 - Задание 3 (фильтруем магазины)

Получаются магазины:


ЕГЭ по информатике ДЕМО 2025 - Задание 3 (фильтруем магазины), результаты

Перейдём на вкладку Товар. Найдём с помощью поиска (Ctrl + F) товар зефир.


ЕГЭ по информатике ДЕМО 2025 - Задание 3 (ищем товар)




Разные виды зефира имеют в упаковке разное количество грамм, поэтому будем с каждым видом работать отдельно.


Переходим на вкладку Движение товаров. Вновь включаем фильтр. Оставляем магазины только M10, M15.


ЕГЭ по информатике ДЕМО 2025 - Задание 3 (оставляем нужные магазины)

Оставим с помощью фильтров только Зефир в шоколаде - артикул 4.


С помощью фильтров оставим только Тип операции "Поступление".


Выделим количество упаковок только за указанные даты.


ЕГЭ по информатике ДЕМО 2025 - Задание 3 (Количество упаковок для данного типа товара)




Внизу справа будет показана сумма выделенных ячеек.


ЕГЭ по информатике ДЕМО 2025 - Задание 3 (Количество упаковок для данного типа товара 2)

Сумма получается равна 1000. Вернёмся на вкладку Товар. Масса одной упаковки данного товара равна 250 грамм = 0,25 кг. Тогда


1000 ∙ 0,25 кг = 250 кг

Аналогично находим массу и для других товаров с артикулами 5, 6, 7. Количество получается везде 1000. Но масса упаковки везде разная.


Для 5: 1000 ∙ 0,8 кг = 800 кг
Для 6: 1000 ∙ 0,5 кг = 500 кг
Для 7: 1000 ∙ 1 кг = 1000 кг

Получается ответ:


250 + 800 + 500 + 1000 = 2550 кг

Ответ: 2550



Задание 4

По каналу связи передаются шифрованные сообщения, содержащие только десять букв: А, B, C, D, E, F, S, X, Y, Z; для передачи используется неравномерный двоичный код. Для кодирования букв используются кодовые слова.


ЕГЭ по информатике ДЕМО 2025 - Задание 4 (Таблица)

Укажите кратчайшее кодовое слово для буквы B, при котором код удовлетворяет условию Фано. Если таких кодов несколько, укажите код с наименьшим числовым значением.

Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.


Решение:

Коды должны удовлетворять условию Фано. Применим приём дерево Фано. Расположим на этом дереве все буквы, которые нам известны.


ЕГЭ по информатике ДЕМО 2025 - Задание 4 (Дерево Фано, решение)

Букве B достаётся код 1000.


Ответ: 1000



Задание 5

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

1. Строится двоичная запись числа N.

2. Далее эта запись обрабатывается по следующему правилу:

а) если число чётное, то к двоичной записи числа слева дописывается 10;

б) если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01.

Полученная таким образом запись является двоичной записью искомого числа R.

3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 410 = 1002 результатом является число 2010 = 101002, а для исходного числа 510 = 1012 это число 5310 = 1101012.

Укажите максимальное число R, которое может быть результатом работы данного алгоритма, при условии, что N не больше 12. В ответе запишите это число в десятичной системе счисления.


Решение:

mx=-10**10
for n in range(1, 1000):
    s=format(n, 'b')
    if n%2==0:
        s = s + '10'
    else:
        s = '1' + s
        s = s + '01'
    r = int(s, 2)
    if n<=12:
        mx=max(mx, r)

print(mx)

Получается ответ 109. Как решать задачи из 5 Задания ЕГЭ по информатике 2025, читайте в статье.


Ответ: 109



Задание 6

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n – целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n – целое число), вызывающая передвижение в противоположном голове направлении; Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке, Налево m (где m – целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.


Черепахе был дан для исполнения следующий алгоритм:


Повтори 9 [Вперёд 22 Направо 90 Вперёд 6 Направо 90]
Поднять хвост
Вперёд 1 Направо 90 Вперёд 5 Налево 90
Опустить хвост
Повтори 9 [Вперёд 53 Направо 90 Вперёд 75 Направо 90]


Определите периметр области пересечения фигур, ограниченных заданными алгоритмом линиями.





Решение:

Пропишем алгоритм для Черепахи в программе Кумире:


использовать Черепаха
алг
нач
  нц 9 раз
    вперед(22)
    вправо(90)
    вперед(6)
    вправо(90)
  кц
  поднять хвост
  вперед(1)
  вправо(90)
  вперед(5)
  влево(90)
  опустить хвост
  нц 9 раз
    вперед(53)
    вправо(90)
    вперед(75)
    вправо(90)
  кц
кон

Нажмём на кнопку "Выполнение".


Установим масштаб в 1.


ЕГЭ по информатике ДЕМО 2025 - Задание 6 (Устанавливаем масштаб)

ЕГЭ по информатике ДЕМО 2025 - Задание 6 (Решение)




Периметр равен:


(1 + 21) ∙ 2 = 44

Решение через Python.


from turtle import *
tracer(0)

left(90)
color('red')
for i in range(9):
    forward(22*10)
    right(90)
    forward(6*10)
    right(90)
    
penup() # Поднять хвост

forward(1*10)
right(90)
forward(5*10)
left(90)

pendown() # Опустить хвост

for i in range(9):
    forward(53*10)
    right(90)
    forward(75*10)
    right(90)

# Рисуем координатную сетку
penup()
for x in range(-100, 100):
    for y in range(-100, 100):
        setpos(x*10, y*10)
        dot(4, 'gray')




Т.к. точек в координатной сетке мы выбрали очень много, возможно, придётся подождать несколько секунд.


ЕГЭ по информатике ДЕМО 2025 - Задание 6 (Решение на python)

Ответ: 44

Задание 7

Прибор автоматической фиксации нарушений правил дорожного движения делает цветные фотографии размером 1024×768 пикселей, используя палитру из 4096 цветов. Снимки сохраняются в памяти камеры, группируются в пакеты по несколько штук, а затем передаются в центр обработки информации со скоростью передачи данных 1 310 720 бит/с. Каково максимально возможное количество снимков в одном пакете, если на передачу одного пакета отводится не более 300 секунд?

В ответе запишите целое число.


Решение:
ЕГЭ по информатике ДЕМО 2025 - Задание 7 (Изображение)




Найдём сколько весит одна точка изображения:


ЕГЭ по информатике - задание 7 (Формула)

N = 2i = 212 = 4096

Значит, 12 бит - весит одна точка. Тогда всё изображение весит:


V = 12 ∙ 1024 ∙768

Обозначим за x - количество снимков в пакете.


Тогда пакет весит:


12 ∙ 1024 ∙768 ∙ x

Учтём, что пакет должен передаваться не более 300 сек.


12 1024 768 x 1 310 720 б и т / с 300
x ≤ 41,6

Максимальное количество изображений в пакете равно 41.


Ответ: 41

Разбор демоверсии ЕГЭ по информатике 2025 (8-14 Задания)
Разбор демоверсии ЕГЭ по информатике 2025 (15-21 Задания)
Разбор демоверсии ЕГЭ по информатике 2025 (22-27 Задание)




28-08-2024 в 21:30:17






Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2025 - Задание 12 (Вперёд, к Победе!)

Сегодня научимся решать 12 задание из ЕГЭ по информатике 2025....

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 01-08-2024 в 09:00:07 0



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.