вентилятор
Хорошего настроения!

ОГЭ по информатике. Нахождение СУММЫ. Задачи на Паскаль (Pascal) - вторая часть.



Задача 1

Напишите программу, которая в последовательности натуральных чисел определяет СУММУ чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – СУММУ чисел.





Решение:

В начале СУММА равна нулю. Перебираем в ЦИКЛЕ числа. Суммируем: То что было в сумме плюс очередной элемент.


Var a, i, sum, n: integer;
begin
  read(n);
  sum:=0;
  for i:=1 to n do
  begin
    read(a);
    sum:= sum + a;
  end;
Writeln(sum);
end.




Нахождение СУММЫ чисел КРАТНЫХ 4.

Задача 2

Напишите программу, которая в последовательности натуральных чисел определяет СУММУ чисел, КРАТНЫХ 4. В последовательности всегда имеется число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – СУММУ чисел, кратных 4.


Решение:

В начале СУММА равна нулю. Перебираем в ЦИКЛЕ числа. Если нам попался элемент кратный 4, то мы суммируем: то что было в сумме плюс наш элемент.


var a, i, sum, n: integer;
begin
  read(n);
  sum:=0;
  for i:=1 to n do
  begin
  read(a);
  if a mod 4 = 0
     then sum:= sum + a;
  end;
  Writeln(sum);
end.




Нахождение СУММЫ чисел, ОКАНЧИВАЮЩИХСЯ на 2.

Задача 9

Напишите программу, которая в последовательности натуральных чисел определяет СУММУ чисел, ОКАНЧИВАЮЩИХСЯ на 2. В последовательности всегда имеется число, ОКАНЧИВАЮЩЕЕСЯ на 2. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – СУММУ чисел, ОКАНЧИВАЮЩИХСЯ на 2.


Решение:

Вначале СУММА равна нулю. Перебираем в ЦИКЛЕ числа. Если нам попался элемент, который оканчивается на 2 то мы суммируем: то что было в сумме плюс наш элемент.


var a, i, sum, n: integer;
begin
  read(n);
  sum:=0;
  for i:=1 to n do
  begin
    read(a);
    if a mod 10 = 2 then
      sum:= sum + a;
  end;
  Writeln(sum);
end.




Нахождение СУММЫ чётных чисел.

Задача 3

Напишите программу, которая в последовательности натуральных чисел определяет СУММУ чётных чисел. В последовательности всегда имеется чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – СУММУ чётных чисел.


Решение:

Вначале СУММА равна нулю. Перебираем в ЦИКЛЕ числа. Если нам попался чётный элемент (остаток от деления на 2 равен нулю), то мы суммируем: то что было в сумме плюс наш элемент.


var a, i, sum, n: integer;
begin
  read(n);
  sum:=0;
  for i:=1 to n do
  begin
    read(a);
    if a mod 2 = 0 then
      sum:= sum + a;
  end;
  Writeln(sum);
end.


23-09-2018 в 12:06:58





Поддержать сайт:


Похожая статья:

ЕГЭ по информатике 2022 - Задание 7 (Фото, звук)

Седьмое задание из ЕГЭ по информатике 2022. Отличное задание, которое ...

Категория: Информатика  Подкатегория: ЕГЭ
Дата: 25-10-2021 в 08:03:38 6



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.