вентилятор
Хорошего настроения!

ЕГЭ по информатике 2023 - Задание 23 (Чудо шаблон!)



Здравствуйте! Сегодня речь пойдёт о 23 задании из ЕГЭ по информатике 2023.


Двадцать третье задание является последним заданием из первой части ЕГЭ по информатике 2023.


Давайте познакомимся с примерными задачами 23 задания из ЕГЭ по информатике 2023.





Задача (классическая)

У исполнителя Удвоитель две команды, которым присвоены номера:


1. прибавить 3,
2. умножить на 2.

Первая из них увеличивает число на экране на 3, вторая - удваивает его.

Программа для Удвоителя - это последовательность команд.

Сколько есть программ, которые число 1 преобразуют в число 25 ?


Решение:

1 способ (самый эффективный, на Python).

def F(x, y):
    if x == y: return 1

    if x > y: return 0

    if x < y: return F(x+3, y) + F(x*2, y)

print(F(1, 25))

Число x, это то число, с которым мы работаем. Число y - это куда нужно прийти.


Если число x достигло пункта назначения, то возвращаем 1. Если оно перескочило y, то возвращаем 0. А если ещё не дошло до y, то продолжаем вычисления с помощью рекурсии.


Ответ получается равен 9.






2 Способ (графический, для понимания)

Начинаем рассматривать задачку с конца. Если число нечётное, то оно может быть получено только с помощью первой команды. Если число чётное, то оно может быть получено с помощью двух команд.



ЕГЭ по информатике - задание 22 (Исполнитель удвоитель)

Видим, что количество программ получается 9!





3 Способ (С помощью таблицы)

Некоторое число i можно получить только двумя способами: либо c помощью первой команды, либо с помощью второй команды. Тогда количество программ для некоторого числа i будет складываться из двух чисел: количества программ для числа i-3 и количества программ для числа i / 2 (Если i - чётное).


Числа 1 2 3 4 5 6 7 8 9 10
+3 - - - 1 2 3 4 5 6 7
*2 - 1 - 2 - 3 - 4 - 5
Кол.
Прог.
1 1 0 2 1 0 2 3 0 3


Числа 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
+3 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
*2 - 6 - 7 - 8 - 9 - 10 - 11 - 12 -
Кол.
Прог.
3 0 3 5 0 6 5 0 6 8 0 9 8 0 9

В первой строке пишутся числа от 1 до 25 (до того числа, которое нужно получить).


Во второй строке пишутся числа, которые в сумме с 3 (тройкой) дают числа, написанные в первой строке. (Прим. начиная с 4, числа идут по порядку.)


В третьей строке пишутся числа, которые при умножении на 2 дают числа, написанные в первой строке. (Прим. числа так же идут по порядку через одну пустую ячейку.)


В четвёртой строке для единицы ставим 1. Для остальных ячеек: смотрим, какие числа участвуют во второй и третьей строке для конкретной ячейки. Затем, эти числа ищем в первой строке и пишем сумму количеств программ для этих чисел (Т.е. пишем сумму уже известных значений из четвёртой строки для этих чисел).


Таким образом, основная идея 23 задания из ЕГЭ по информатике заключается в том, что результат каждого шага опирается на результаты предыдущих шагов!


Получаем ответ 9!


Ответ: 9



Задача (с избегаемым узлом)

Исполнитель НечетМ преобразует число на экране. У исполнителя НечетМ две команды, которым присвоены номера:


1. прибавь 1
2. сделай нечётное

Первая из этих команд увеличивает число x на экране на 1, вторая переводит число x в число 2x+1. Например, вторая команда переводит число 10 в число 21. Программа для исполнителя НечетМ — это последовательность команд. Сколько существует таких программ, которые число 1 преобразуют в число 25, причём траектория вычислений не содержит число 24? Траектория вычислений программы — это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 7 траектория будет состоять из чисел 8, 17, 18.


Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304



Решение:

1 способ (самый эффективный, на Python).

def F(x, y):
    if x == y: return 1

    if x > y or x==24: return 0

    if x < y: return F(x+1, y) + F(x*2+1, y)

print(F(1, 25))

Здесь на нельзя получать число 24, поэтому, если x будет равен 24, то мы возвращаем ноль.


Ответ получается равен 10.





2 способ (Решение с помощью таблицы).


Мы не может получать число 24! Значит, единственным способом добраться до числа 25 будет вторая команда.


Получается, что сначала нужно получить число 12, тогда 2 * 12 + 1 = 25 (2x+1). Это единственный путь!


Каждое число можем получить только 2 способами (Либо с помощью первой команды, либо с помощью второй команды). Поэтому количество программ для некоторого числа i будет равно сумме количеств команд для числа i-1 и для числа (i - 1) / 2 (Если число нечётное.) Если число i - чётное, то до числа i можно добраться единственным способом (с помощью первой команды).


Если записать с помощью массива:


A[i]=A[i-1] - если i - четное.
A[i]=A[i-1] + A[(i-1)/2] - если i нечетное;

Числа 1 2 3 4 5 6 7 8 9 10 11 12
2x+1 - - 1 - 2 - 3 - 4 - 5 -
+1 - 1 2 3 4 5 6 7 8 9 10 11
Кол.
Прог.
1 1 2 2 3 3 5 5 7 7 10 10

Ответ: 10



Задача (ЕГЭ по информатике, Москва, 2019)

У исполнителя есть три команды, которым присвоены номера:


1. Прибавить 1
2. Умножить на 3
3. Прибавить 2

Первая команда увеличивает число на экране на 1, вторая умножает его на 3, третья увеличивает его на 2.

Сколько существует программ, которые преобразуют исходное число 2 в число 12 и при этом траектория вычислений содержит число 9 и число 11?


Траектория вычислений программы - это последовательность результатов выполнения всех команд программы. Например, для программы 132 при исходном числе 7 траектория будет состоять из чисел 8, 10, 30.


Решение:

1 способ (самый эффективный, на Python).

def F(x, y):
    if x == y: return 1

    if x > y: return 0

    if x < y: return F(x+1, y) + F(x*3, y) + F(x+2, y)

print(F(2, 9)*F(9, 11)*F(11, 12))


У нас числа 9 и 1 обязательные, поэтому разбиваем функцию следующим образом F(2, 9)*F(9, 11)*F(11, 12), через умножение. Это и будет ответ. Получается 50.





2 способ (с помощью таблицы).

От числа 11 до числа 12 можно добраться единственным путём (11 + 1 = 12).


От числа 9 до числа 11 можно добраться двумя способами (9 + 1 + 1 = 11, 9 + 2 = 11).


Найдём сколькими способами можно попасть от числа 2 до числа 9.


Числа 2 3 4 5 6 7 8 9
+1 - 2 3 4 5 6 7 8
*3 - - - - 2 - - 3
+2 - - 2 3 4 5 6 7
Кол-во
программ
1 1 2 3 6 9 15 25

Учитывая, что от 9 до 11 двумя способами можно добраться, то 25 * 2 = 50 - это и будет ответ.


Ответ: 50

Задача ( ЕГЭ по информатике, Москва, 2020)

У исполнителя есть три команды, которым присвоены номера:


1. Прибавить 1
2. Умножить на 3
3. Прибавить 2

Первая команда увеличивает число на экране на 1, вторая умножает его на 3, третья увеличивает на 2.

Сколько существует программ, которые преобразуют исходное число 3 в число 14 и при этом траектория вычислений содержит число 9?

Траектория вычислений программы - это последовательность результатов выполнения всех команд программы. Например, для программы 132 при исходном числе 7 траектория будет состоять из чисел 8, 10, 30.


Решение:

1 способ (самый эффективный, на Python).

def F(x, y):
    if x == y: return 1

    if x > y: return 0

    if x < y: return F(x+1, y) + F(x*3, y) + F(x+2, y)

print(F(3, 9)*F(9, 14))

Ответ получается 112.





2 способ (с помощью таблицы).

Последней командой для получении любого числа из траектории программы может быть одна из трёх выше указанных команд!


Значит, количество программ для некоторого числа будет складываться из количества программ для тех чисел, из которых это число может быть получено.


Получается, что мы будем использовать основной принцип 23 задания из ЕГЭ по информатике: результат для некоторого числа опирается на результаты предыдущих чисел. Т.к. траектория вычислений программ обязательно должна проходить через число 9, то при вычислении результата для чисел больших 9, мы не можем опираться на результаты для чисел меньших 9 (Иначе мы пропустим число 9).


Числа 3 4 5 6 7 8 9 10 11 12 13 14
+1 - 3 4 5 6 7 8 9 10 11 12 13
*3 - - - - - - 3 - - - - -
+2 - - 3 4 5 6 7 - 9 10 11 12
Кол-во
программ
1 1 2 3 5 8 14 14 28 42 70 112

Ответ: 112



Посмотрим следующую задачу из 23 задания ЕГЭ по информатике 2023


Задача (с обязательным узлом, закрепление)

Исполнитель Май17 преобразует число на экране.

У исполнителя есть две команды, которым присвоены номера:


1. Прибавить 1
2. Прибавить 3

Первая команда увеличивает число на экране на 1, вторая увеличивает его на 3. Программа для исполнителя Май17 — это последовательность команд.


Сколько существует программ, для которых при исходном числе 1 результатом является число 17 и при этом траектория вычислений содержит число 9?


Траектория вычислений программы — это последовательность результатов выполнения всех команд программы. Например, для программы 12 при исходном числе 7 траектория будет состоять из чисел 8, 11, 12.



Решение:

1 способ (самый эффективный, на Python).

def F(x, y):
    if x == y: return 1

    if x > y: return 0

    if x < y: return F(x+1, y) + F(x+3, y)

print(F(1, 9)*F(9, 17))

Ответ получается 169.





2 способ (с помощью таблицы).

Любое число может получится в результате двух команд! Тогда количество программ для числа i будет складываться из количеств команд для числа i - 1 и для числа i - 3.


Если написать на языке массива


A[i] := A[i-1] + A[i-3], при i > 3.


Числа 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
+1 - 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
+3 - - - 1 2 3 4 5 6 - - 9 10 11 12 13 14
Кол-во
программ
1 1 1 2 3 4 6 9 13 13 13 26 39 52 78 117 169

При составлении значения для числа 10, мы не имеем право "заглядывать" за число 9, иначе число 9 будет пропущено! Поэтому для следующих трёх чисел (9, 9 + 1, 9 + 1 + 1), начиная с 9, будет 13 программ.


Для числа 17 получается ответ 169.


Ответ: 169




26-07-2022 в 08:30:14





Поддержать сайт:


Похожая статья:

ОГЭ по информатике 2020 - Задание 1 (Бомбим экзамен!)

Наконец-то выходит первый видеоурок по новой версии ОГЭ по информатик...

Категория: Информатика  Подкатегория: ОГЭ
Дата: 04-12-2019 в 15:47:40 2


Комментарии:

спасибо вам огромное за вашу работу! самый лучший сайт!
Анастасия Иванишина 18-12-2022 в 05:20:57

Спасибо огромное! Ваш сайт очень помогает!!!!!
Ольга 26-02-2023 в 14:19:59

топ
даня 27-04-2023 в 07:47:09

Очень крутые решения, помогают очень. Спасибо!
Аноним 08-08-2023 в 22:03:03

СПАСИБО
СВЕТ 01-12-2023 в 23:28:38

Лучший разбор , что ягде либо встречал .Спасибо!!
Абракадабра 27-02-2024 в 18:29:50



Оставить коментарий:



Напишите email, чтобы получать сообщения о новых комментариях (необязательно):


Задача против робота. Расположите картинки горизонтально:




Нажимая кнопку Отправить, Вы соглашаетесь с политикой конфиденциальности сайта.